wiki:CygwinPort

Version 29 (modified by was, 11 years ago) (diff)

--

Here is a list (in-progress) of the things needs to get Sage to build (and pass most tests) on Cygwin:

Cygwin Prerequisites

These Cygwin packages need to be installed in order for the Sage build to complete.

  • file, liblapack, liblapack0, liblapack-devel

Tickets

  • #9146 -- cygwin: gd doesn't correctly link in libpng with sage-4.4.3.
  • #8257: gd needs a better version of expr
  • #7321: numpy fails to build on cygwin due to not using the correct fortran compiler
  • #8780: Add cephes spkg for Cygwin (provides complex.h amongst other things)
  • #8782: pari does not work under Cygwin
  • #8907: Python should be build with enable-shared
  • #9050: libntl.dll should be libntl.dll.a
  • #8542 / #8903: Pynac needs to use a function pointer table.
  • libflint.dll needs to be libflint.so, or polynomial_integer_dense_flint.pyx needs to know to use the .dll (maybe not a real issue, let's wait an see on this one).
  • #8642: port detection for the notebook does not work in Cygwin
  • #8855: sage-env needs to be updated for Cygwin
  • #8853: fix M_PI_4 in complex_double on Cygwin
  • #8852: minor doctest fix in fast_eval.pyx for Cygwin
  • #8850: Cython should link against BLAS instead of ATLAS on Cygwin
  • #8849: the palp interface throws a (harmless?) OSError on Cygwin
  • #9067: boehm_gc (still) fails to build on Cygwin

Possible issue with Python 2.6:

http://groups.google.com/group/sage-windows/browse_thread/thread/88499b995a22ecc1

(I had no problems with that thus far in Vista Premium 32-bit -Alec Mihailovs)

(Alec - Win7 has a newer codebase, so this is not really a proof that we need not worry --- I think we really need to. Dmitrii)