Opened 9 years ago

Last modified 7 years ago

#9975 closed defect

Update GnuTLS and clean up the package — at Initial Version

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords: sd32
Cc: leif, drkirkby Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The current version of GnuTLS in Sage has multiple issues, not all of which will probably be solved by this ticket, but at least of subset of them will be.

  • The current version in Sage is very old.
  • There are security issues with the current version - see #7542
  • There's no spkg-check file - see #9308
  • It fails to build on AIX - see #9974
  • It fails to build on HP-UX - see #7511
  • make is used instead of $MAKE
  • -m64 is hard-coded as the compiler flag needed for 64-bit builds
  • SPKG.txt lacks the Special Update/Build Instructions section.
  • There's an incomplete list of dependencies in SKG.txt, with a remark to FIXME

Change History (0)

Note: See TracTickets for help on using tickets.