Opened 11 years ago

Closed 11 years ago

#9956 closed defect (duplicate)

latex(-1/2 * polynom) broken

Reported by: schilly Owned by: burcin
Priority: critical Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Notice that in the latex expression the negative coefficient applies only to the 4*m2 term in the numerator thus giving a completely different value.

sage: var('t k m')
sage: latex(-1/2*(4*m^2 - 9*m - t + 8)/m)
\frac{-4 \, m^{2} - 9 \, m - t + 8}{2 \, m}

Note: This was reported via the "report a problem" form for 4.5.2 for the "typset" option in the notebook, and I confirmed this on 4.5.3 for this simpler example.

Change History (1)

comment:1 Changed 11 years ago by burcin

  • Milestone changed from sage-4.6 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

After installing the pynac package at #9901, this works for me:

sage: var('t k m')
(t, k, m)
sage: latex(-1/2*(4*m^2 - 9*m - t + 8)/m)
-\frac{4 \, m^{2} - 9 \, m - t + 8}{2 \, m}

Although the problem was never reported in this form, which is much more severe, #9834 and #9394 already cover this. I'm closing this as a duplicate.

Feel free to mark one/all of the tickets mentioned above as blockers.

Note: See TracTickets for help on using tickets.