Opened 10 years ago

Closed 7 years ago

#9875 closed defect (worksforme)

Can't upload from a notebook link, only from a .sws file

Reported by: kcrisman Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers: Karl-Dieter Crisman
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by kcrisman)

Using the 'upload' dialogue in the notebook, where it says to put in a URL, currently it must be a link to a .sws file (which is said).

But since the links in /pub/ when you click on Published are given in the form http://www.sagenb.org/home/pub/2423, you should really be able to just give this as a link instead of a .sws file, which requires the additional step of clicking on the link and then copying the 'Download' link for use in the 'upload' dialogue. But this causes an error currently.

Alternately, creating a link directly to the .sws on each worksheet list (including /pub/) would be ok, but I think that's inferior and less elegant.

Change History (10)

comment:1 Changed 10 years ago by jason

Can you be more clear in your description? I'm really confused by your description.

comment:2 Changed 10 years ago by kcrisman

  • Description modified (diff)

Better?

comment:3 Changed 10 years ago by jason

Much better. I agree that putting in the URL of a published worksheet would be nice to work.

comment:4 Changed 10 years ago by nthiery

Is this a duplicate of #7441?

Related ticket #10652 (shameless plug)

comment:5 Changed 10 years ago by jason

I think you're right that it is a duplicate of #7441

comment:6 Changed 10 years ago by kcrisman

I've asked some questions on #7441 to verify whether this issue is also taken care of by the patches at #7441. The description of #7441 is a dup, but the patches might not do exactly what this asks (namely, allowing *old* published worksheets to be uploaded from some server, and not needing the html ending).

comment:7 Changed 8 years ago by kcrisman

It's conceivable that this is resolved by this github PR, but not necessarily, since the file ending might not be taken care of.

comment:8 Changed 7 years ago by kcrisman

  • Reviewers set to Karl-Dieter Crisman
  • Status changed from new to needs_review

I believe this request did indeed take care of it! At least, in Sage 5.6 I can confirm that just entering a link of the form

http://sage....edu/home/pub/73/

worked nicely. Jason, can you try this? I'd like to have dual confirmation that I'm not crazy.

comment:9 Changed 7 years ago by kcrisman

  • Milestone changed from sage-5.11 to sage-duplicate/invalid/wontfix
  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.
  • Status changed from needs_review to positive_review

Okay, it was actually this commit of Dan Drake's. Yay!

comment:10 Changed 7 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.