Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#9854 closed enhancement (invalid)

make networkx compatibel with numpy-1.4.1

Reported by: Stefan Reiterer Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Stefan Reiterer Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by Stefan Reiterer)

In order to finish Ticket #9808 there have to be a small patch applied to networkx.

A small change has to be done in convert.py, namely

numpy.core.defmatrix

changes to

numpy.matrixlib.defmatrix

(see the diff for details)

Attachments (3)

convert.py.diff (626 bytes) - added by Stefan Reiterer 12 years ago.
changes
convert.py.2.diff (1.6 KB) - added by Stefan Reiterer 12 years ago.
Downward compatibel patch
networkx-1.0.1.p0.spkg (664.2 KB) - added by Stefan Reiterer 12 years ago.
modified version for networkx to make numpy-1.4.1 compatible

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by Stefan Reiterer

Description: modified (diff)

Changed 12 years ago by Stefan Reiterer

Attachment: convert.py.diff added

changes

comment:2 Changed 12 years ago by Stefan Reiterer

Status: newneeds_review

comment:3 Changed 12 years ago by Stefan Reiterer

Description: modified (diff)

Changed 12 years ago by Stefan Reiterer

Attachment: convert.py.2.diff added

Downward compatibel patch

Changed 12 years ago by Stefan Reiterer

Attachment: networkx-1.0.1.p0.spkg added

modified version for networkx to make numpy-1.4.1 compatible

comment:4 Changed 12 years ago by Stefan Reiterer

Description: modified (diff)

comment:5 Changed 12 years ago by François Bissey

As I mentioned in the numpy upgrade bug we are moving to networkx-1.2. So this bug may be invalid. Check have to be done against networkx-1.2 not 1.0.1.

comment:6 Changed 12 years ago by Stefan Reiterer

Ok like mentioned in #9808 networkx-1.2 works with the numpy packages just fine. But I had to install a new version, because I was not able to just install networkx-1.2 into my old version of sage-4.2. After intalling it and applying the patches it still didn't work correctly. But the patch of 1.0.1 above worked well for me. So it could still be usefull. But I think we could close this ticket then.

comment:7 Changed 12 years ago by Stefan Reiterer

Resolution: fixed
Status: needs_reviewclosed

comment:8 Changed 12 years ago by Minh Van Nguyen

Milestone: sage-4.5.3
Status: closedneeds_work

How is this ticket considered fixed? Do you want the attached NetworkX package to be merged in the Sage standard repository? If so, has it been merged yet? If not, you need to explain why you closed this ticket.

comment:9 in reply to:  8 Changed 12 years ago by François Bissey

Resolution: fixedinvalid
Status: needs_workclosed

Replying to mvngu:

How is this ticket considered fixed? Do you want the attached NetworkX package to be merged in the Sage standard repository? If so, has it been merged yet? If not, you need to explain why you closed this ticket.

It should have been closed invalid. Numpy-1.4.1 and networkx-1.0.1 don't go along very well together. But it doesn't matter since next sage release will use networkx-1.2 which works well with numpy-1.4.1. I am changing it to "invalid".

comment:10 Changed 12 years ago by Minh Van Nguyen

Milestone: sage-4.5.3sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.