Opened 12 years ago

Last modified 8 years ago

#9827 closed defect

Intermittent doctest failure in sage/interfaces/psage.py — at Version 5

Reported by: mpatel Owned by: was
Priority: major Milestone: sage-6.4
Component: interfaces Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by jdemeyer)

This happens sometimes:

sage -t --long devel/sage/sage/interfaces/psage.py
**********************************************************************
File "devel/sage/sage/interfaces/psage.py", line 37, in sage.interfaces.psage
Failed example:
    w       # long time, random output
Exception raised:
    Traceback (most recent call last):
      File "/release/buildbot/sage/sage-1/sage_upgrade_4.8/build/sage-5.9.beta4/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 466, in _run
        self.execute(example, compiled, test.globs)
      File "/release/buildbot/sage/sage-1/sage_upgrade_4.8/build/sage-5.9.beta4/local/lib/python2.7/site-packages/sage/doctest/forker.py", line 825, in execute
        exec compiled in globs
      File "<doctest sage.interfaces.psage[3]>", line 1, in <module>
        w       # long time, random output
      File "/release/buildbot/sage/sage-1/sage_upgrade_4.8/build/sage-5.9.beta4/local/lib/python2.7/site-packages/sage/misc/displayhook.py", line 201, in __call__
        self.oldhook(obj)
      File "/release/buildbot/sage/sage-1/sage_upgrade_4.8/build/sage-5.9.beta4/local/lib/python2.7/site-packages/sage/interfaces/interface.py", line 880, in __repr__
        s =  s.replace(self._name, self.__dict__['__custom_name'])
    KeyError: '__custom_name'
**********************************************************************

See this reply (and possible follow-ups) for batch-testing results for psage.py.

Distantly related: #1991.

Change History (6)

comment:1 Changed 12 years ago by mpatel

Near the top of sage/interfaces/psage.py is a possibly relevant note:

BUG -- currently non-idle PSage subprocesses do not stop when
\sage exits.  I would very much like to fix this but don't know how.

comment:2 Changed 9 years ago by roed

Is this still relevant after #12415?

comment:3 Changed 9 years ago by roed

  • Component changed from doctest to interfaces
  • Owner changed from mvngu to was

I don't think this has to do with doctesting...

comment:4 Changed 9 years ago by jdemeyer

  • Description modified (diff)
  • Milestone set to sage-5.10

comment:5 Changed 9 years ago by jdemeyer

  • Description modified (diff)

Changed 9 years ago by jdemeyer

Note: See TracTickets for help on using tickets.