Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#9821 closed defect (duplicate)

problems with infinite polynomial rings

Reported by: fwclarke Owned by: malb
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: commutative algebra Keywords: infinite polynomial ring
Cc: Merged in:
Authors: Francis Clarke Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The functions is_field and is_integral_domain for infinite polynomial rings lack the keyword proof. This can give rise to errors. For example,

sage: R.<x> = InfinitePolynomialRing(ZZ)
sage: A.<t> = R[[]]

Attachments (2)

trac_9821.patch (1.9 KB) - added by fwclarke 11 years ago.
trace_9821-replacement.patch (3.5 KB) - added by fwclarke 11 years ago.
replaces previous patch

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by fwclarke

comment:1 Changed 11 years ago by fwclarke

  • Status changed from new to needs_review

The patch fixes the problem. There were actually two definitions of is_field in the file. One has been deleted and the other modified.

comment:2 follow-up: Changed 11 years ago by mhansen

Could you add a doctest testing the proof parameter.

(Note that this is a duplicate of #9589, but I think this one can get resolved quicker.)

comment:3 in reply to: ↑ 2 Changed 11 years ago by fwclarke

Replying to mhansen:

Could you add a doctest testing the proof parameter.

This has turned out to be more difficult than expected, but I do now have a replacement patch. In order to create a reasonable doctest I had to correct a bug in sage.rings.quotient_rings.QuotientRing_generic.is_integral_domain

At the same time I have eliminated the Integer(8) example from that function's doctests, since that ring uses code from sage/rings/finite_rings/integer_mod_ring.pyx rather than from quotient_rings.

I didn't think it worth including an example of the use of proof in is_field because the parameter is ignored.

(Note that this is a duplicate of #9589, but I think this one can get resolved quicker.)

(You must have meant #9549)

Changed 11 years ago by fwclarke

replaces previous patch

comment:4 Changed 10 years ago by fwclarke

  • Resolution set to duplicate
  • Status changed from needs_review to closed

This has been fixed by #9443. This ticket was actually a triplicate!

The bug in is_integral_domain for generic quotient rings is now the subject of #10219.

comment:5 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.6.1 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.