Opened 11 years ago

Last modified 11 years ago

#9768 closed defect

Fix PolyBoRi's broken dynamic libraries — at Version 1

Reported by: AlexanderDreyer Owned by: AlexanderDreyer
Priority: major Milestone: sage-4.6
Component: packages: standard Keywords:
Cc: PolyBoRi, malb, wjp, mvngu Merged in:
Authors: AlexanderDreyer Reviewers:
Report Upstream: Fixed upstream, in a later stable release. Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by AlexanderDreyer)

In #8830 we worked around PolyBoRi's broken dynamic libraries by removing them after build, hence using the static ones instead. The problem was caused by improper handling of a global variable which was fixed for upcoming PolyBoRi 0.7.

The package at http://sage.math.washington.edu/home/dreyer/pb/polybori-0.6.4.p5.spkg backports this fix and reintroduces the dynamic libraries. The spkg is based on #9717 and assumes its sage-library patch to be applied. It installs, runs and passed testall on boxen.

Change History (2)

Changed 11 years ago by AlexanderDreyer

Diffs of the new package

comment:1 Changed 11 years ago by AlexanderDreyer

  • Description modified (diff)
Note: See TracTickets for help on using tickets.