Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9767 closed defect (duplicate)

Cliquer has no spkg-check file, but there is a small test suite with the program

Reported by: drkirkby Owned by: drkirkby
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: spkg-check Keywords:
Cc: ncohen, leif, Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

There's a test suite which can be run easily - see below.

drkirkby@hawk:~/cliquer-1.2.p6/src$ make testcases
gcc -Wall -O3 -fomit-frame-pointer -funroll-loops   -c -o testcases.o testcases.c
gcc  -o testcases testcases.o cliquer.o graph.o reorder.o
drkirkby@hawk:~/cliquer-1.2.p6/src$ ./testcases

Running testcases:  ELEMENTSIZE=32, sizeof(setelement)=4  (OK)

Testing small: graph_test...OK
Testing large: graph_test...OK
Testing wlarge: graph_test...OK

Testing small: single maximum clique...OK
Testing large: single maximum clique...OK
Testing small: single 3-sized clique...OK
Testing large: single 8-sized clique...OK

Testing small: all maximum cliques...OK
Testing large: all maximum cliques...OK
Testing small: all min 3-sized cliques...OK
Testing large: all min 8-sized cliques...OK
Testing large: all exactly 8-sized cliques...OK

Testing large: max clique size...OK
Testing weighted large: max clique weight...OK

Testing large: user_function w/ abort for 8-sized cliques...OK
Testing large: too small array for all maximum cliques...OK

Testing weighted large: single max weighted clique...OK (w=66)
Testing weighted large: single min 60 weighted clique...OK (w=63)
Testing weighted large: single exactly 62 weighted clique...OK (w=62)
Testing weighted large: all max weighted cliques...OK
Testing weighted large: all min 60 weighted cliques...OK
Testing weighted large: all 60...64 weighted maximal cliques...OK

Testing re-entrance...OK
drkirkby@hawk:~/cliquer-1.2.p6/src$ 

Change History (4)

comment:1 Changed 9 years ago by leif

Dave, be warned: You'll hate me if I should review this (spkg-install, patches/Makefile).

comment:2 Changed 9 years ago by leif

Also note that the upstream directory (src/) is not vanilla.

comment:3 Changed 9 years ago by drkirkby

  • Resolution set to duplicate
  • Status changed from new to closed

I realise this is a duplicate of #9521

comment:4 Changed 9 years ago by mvngu

  • Milestone changed from sage-4.6 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.