Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9681 closed defect (wontfix)

Missing dependancy in spkg/standard/deps for zn_poly.

Reported by: drkirkby Owned by: GeorgSWeber
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: ddrake, mpatel, leif, jhpalmieri Merged in:
Authors: David Kirkby Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by drkirkby)

The zn_poly package lists in SPKG.txt the only dependencies are GMP, but this is not true, as zn_poly's configure script has in it:

/configure --gmp-prefix="$SAGE_LOCAL" --ntl-prefix="$SAGE_LOCAL" \
            --prefix="$SAGE_LOCAL" --cflags="$CFLAGS" --ldflags="$LDFLAGS"

So zn_poly depends on ntl

Looking at $SAGE_ROOT/spkg/standard/deps, I see:

$(INST)/$(ZNPOLY): $(BASE) $(INST)/$(MPIR)
        $(INSTALL) "$(SAGE_SPKG) $(ZNPOLY) 2>&1" "tee -a $(SAGE_LOGS)/$(ZNPOLY).log"

i.e. no such dependency is directly listed.

Then looking at MPIR I see the dependencies are only BASE and ICONV. But ICONV only depends on BASE, so there is nothing to force ntl to build before zn_poly, despite zn_poly depends on ntl

I am aware of two other changes that are desirable in the 'deps' file too, as they add clarity.

These might as well be fixed at the same time.

Dave

Attachments (2)

deps (18.4 KB) - added by drkirkby 11 years ago.
Updated deps file, which solves this major problem and corrects two minor ones in #9464 and #9637
deps.diff (1.5 KB) - added by drkirkby 11 years ago.
Unifier diff file for $SAGE_ROOT/spkg/standard/deps

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by drkirkby

  • Description modified (diff)

Changed 11 years ago by drkirkby

Updated deps file, which solves this major problem and corrects two minor ones in #9464 and #9637

Changed 11 years ago by drkirkby

Unifier diff file for $SAGE_ROOT/spkg/standard/deps

comment:2 Changed 11 years ago by drkirkby

  • Status changed from new to needs_review

comment:3 Changed 11 years ago by drkirkby

I've attached an updated 'deps' file, which fixed this major problem and two minor ones - #9464 and #9637. If this ticket is merged, then #9464 and #9637 can be closed as fixed.

Dave

comment:4 Changed 11 years ago by drkirkby

  • Cc ddrake mpatel leif added

It was only by chance I found this, while trying to resolve a 64-bit Solaris issue, which is #9358.

I'm adding the two release managers to the ticket, as I believe this should be a blocker.

Dave

comment:5 Changed 11 years ago by drkirkby

  • Authors set to David Kirkby

comment:6 Changed 11 years ago by mpatel

  • Cc jhpalmieri added

comment:7 follow-up: Changed 11 years ago by robertwb

Unless it's actually causing problems for builds, or giving incorrect results, I wouldn't classify this a as a blocker (though I'd say it is a bug for sure).

comment:8 in reply to: ↑ 7 Changed 11 years ago by drkirkby

Replying to robertwb:

Unless it's actually causing problems for builds, or giving incorrect results, I wouldn't classify this a as a blocker (though I'd say it is a bug for sure).

Some rather subtle problems have been caused by dependencies which have not been correct - I'm thinking in particular of William's failure on OS X to compile some Fortran code, when in fact it was due to the fortran package being dependent on python for a very simple script. The strange thing about that was everyone else had no problems, including me, using William's script on bsd.math.

I would have thought anything that had the potential to mis-compile would be a blocker personally, but that's a personal opinion of course.

Dave

comment:9 Changed 11 years ago by drkirkby

  • Milestone changed from sage-4.5.2 to sage-4.5.1
  • Priority changed from blocker to minor
  • Resolution set to wontfix
  • Status changed from needs_review to closed

Apparently NTL is not needed unless one makes those targets, so this is a non-issue.

comment:10 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.5.1 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.