Opened 11 years ago

Closed 10 years ago

Last modified 10 years ago

#9641 closed defect (duplicate)

Race condition with sage -tp

Reported by: robertwb Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: craigcitro Merged in:
Authors: Reviewers: Willem Jan Palenstijn
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

All files are named .sage/tmp/filename. At high parallelism, there are often conflicts (e.g. all.py, proof.py, ...) that result in untested code and spurious errors.

Change History (4)

comment:1 Changed 11 years ago by AlexGhitza

  • Component changed from algebra to doctest
  • Owner changed from AlexGhitza to mvngu

comment:2 Changed 10 years ago by wjp

Is this a duplicate of #9739 ? (This one is older, but #9739 has work in progress.)

comment:3 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Willem Jan Palenstijn
  • Status changed from new to closed

comment:4 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.6.1 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.