Opened 11 years ago

Closed 8 years ago

#9632 closed defect (fixed)

System-dependent term order for printed expressions

Reported by: mpatel Owned by: burcin
Priority: major Milestone: sage-5.11
Component: symbolics Keywords:
Cc: burcin, cwitty, ddrake, jhpalmieri, kcrisman Merged in: sage-5.11.rc0
Authors: Burcin Erocal Reviewers: Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by burcin)

The order in which the terms in some symbolic expressions are printed depends on the platform/system. For example, evaluating cos(x) + zeta(x) yields

  • zeta(x) + cos(x) on Linux
  • cos(x) + zeta(x) on OS X

in Sage 4.4.4 and 4.5.2.alpha{0,1}, at least.

Please see #9582 for some details and discussion.

Apply: trac_9632-doctests.patch

Attachments (1)

trac_9632-doctests.patch (827 bytes) - added by burcin 8 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by burcin

  • Milestone set to sage-4.6.1
  • Status changed from new to needs_work

#10282 is a duplicate of this issue.

The patches attached to #9880 fix this.

comment:2 Changed 10 years ago by kcrisman

#10282 almost certainly is the same thing.

comment:3 Changed 10 years ago by kcrisman

When this is closed (which would hopefully happen with #9880 integrated), let's be sure to write doctests for both this ticket and #10282, which would just be to say that

sage: psi(1,1/3)*log(3)
log(3)*psi(1, 1/3)

is the same on all systems, in addition to the zeta(x)+cos(x) example here.

Changed 8 years ago by burcin

comment:4 Changed 8 years ago by burcin

  • Authors set to Burcin Erocal
  • Description modified (diff)
  • Status changed from needs_work to needs_review

This was fixed by #9880. trac_9632-doctests.patch adds doctests.

comment:5 Changed 8 years ago by vbraun

  • Reviewers set to Volker Braun
  • Status changed from needs_review to positive_review

comment:6 Changed 8 years ago by jdemeyer

  • Cc changed from burcin, cwitty, ddrake, jhpalmieri, kcrisman to burcin, cwitty, ddrake, jhpalmieri, kcrisman
  • Merged in set to sage-5.11.rc0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.