Opened 10 years ago

Closed 8 years ago

#9602 closed defect (worksforme)

Fix gap on FreeBSD

Reported by: pjeremy Owned by: pjeremy
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: BSD Keywords:
Cc: Merged in:
Authors: Reviewers: Stephen Montgomery-Smith, Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

gap sysfiles.c is very host-dependent. Current code includes a mixture of SYS_xxx and HAVE_xxx_H tests. Whilst SYS_BSD might appear logical for FreeBSD, there is no testing for this, and recent FreeBSD variants support termios.h.

The attached patches (mostly taken from the FreeBSD port) add tests for HAVE_TERMIOS_H to make gap compile on FreeBSD 8.x.

Attachments (2)

gap-4.4.12.p4.patch (2.5 KB) - added by pjeremy 10 years ago.
spkg-patch-gap-4.4.12.p6 (2.5 KB) - added by kcrisman 9 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by pjeremy

comment:1 Changed 9 years ago by kcrisman

Stephen Montgomery-Smith has successfully compiled with a very similar (identical?) patch, attached.

Changed 9 years ago by kcrisman

comment:2 Changed 9 years ago by stephen

I can confirm that this patch is needed to build sage-5.0.beta12. It would be great if this patch could get put into sage. It should be harmless to the builds under all other OS.

comment:3 Changed 9 years ago by leif

Just for the record:

There's also a new GAP spkg at #7041; one should perhaps base a new one here on the latter, although it currently doesn't yet use patch. (I've added a couple of TODOs, some of which I'll probably address at #7041 as well, if I find the time...)

comment:4 Changed 9 years ago by kcrisman

  • Authors set to Peter Jeremy, Stephen Montgomery-Smith
  • Reviewers set to Stephen Montgomery-Smith

Since #7041 didn't use patch, I don't think we need to do this either.

So we need a new spkg with this patch.

comment:5 Changed 8 years ago by kcrisman

Just FYI to all reading this, there is an even newer GAP with a number of things fixed in spkg-install in Sage 5.6.rc0. So it's possible that this would have to be rebased ... or maybe even unnecessary? (We can hope!)

comment:6 Changed 8 years ago by vbraun

  • Milestone changed from sage-5.8 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

The current GAP-4.[5.6].x doesn't have a SYS_BSD macro any more. This suggests that the issue has been fixed by upstream. I'm proposing to close this ticket as invalid/wontfix.

comment:7 Changed 8 years ago by kcrisman

Stephen, what do you think? Your port doesn't seem to have the GAP-specific patch I attached any more.

comment:8 Changed 8 years ago by stephen

Yes, at some point I seem to have removed the patch. So it must be unnecessary now.

comment:9 Changed 8 years ago by vbraun

  • Status changed from needs_review to positive_review

I'll take that as a "positive review"

comment:10 Changed 8 years ago by kcrisman

  • Authors Peter Jeremy, Stephen Montgomery-Smith deleted
  • Reviewers changed from Stephen Montgomery-Smith to Stephen Montgomery-Smith, Volker Braun

comment:11 Changed 8 years ago by kcrisman

  • Report Upstream changed from Not yet reported upstream; Will do shortly. to N/A

comment:12 Changed 8 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.