Opened 12 years ago

Closed 12 years ago

#9573 closed defect (fixed)

Error building the PDF reference manual

Reported by: Mitesh Patel Owned by: Andrey Novoseltsev
Priority: blocker Milestone: sage-4.5.2
Component: documentation Keywords:
Cc: Andrey Novoseltsev, Volker Braun, David Loeffler Merged in: sage-4.5.2.alpha1
Authors: Andrey Novoseltsev Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Building the PDF reference manual for the forthcoming Sage 4.5.2.alpha0 on sage.math, I get

[4610] [4611]
Underfull \hbox (badness 10000) in paragraph at lines 373276--373277

[4612] [4613] [4614] [4615] [4616] [4617] [4618]
(/usr/share/texmf-texlive/tex/latex/ucs/data/uni-4.def)
! Undefined control sequence.
\u-default-1065 #1->\CYRSHCH

l.373945 ...@PYGaB["]@PYGaB[Щ@_45]@PYGaB["]@rb[])

?

The problem may be in schemes/generic/toric_variety.py (cf. #8988).

Attachments (1)

trac_9573_fix_cyrillic_character_in_docstring_problem.patch (1021 bytes) - added by Andrey Novoseltsev 12 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by Mitesh Patel

Here is the full pdflatex log.

comment:2 Changed 12 years ago by Andrey Novoseltsev

Owner: changed from Minh Van Nguyen to Andrey Novoseltsev

I'll fix this. It is a cool non-alphanumeric symbol "Щ" that cannot be used as a variable name...

comment:3 Changed 12 years ago by Mitesh Patel

Out of curiosity: Does it help to replace r""" with ur""" for the relevant docstring?

Changed 12 years ago by Andrey Novoseltsev

comment:4 in reply to:  3 Changed 12 years ago by Andrey Novoseltsev

Authors: Andrey Novoseltsev
Status: newneeds_review

Replying to mpatel:

Out of curiosity: Does it help to replace r""" with ur""" for the relevant docstring?

I don't know, but I think using "@" here as an example of an unacceptable character is more robust and appropriate.

I apologize for the caused problem.

comment:5 Changed 12 years ago by Mitesh Patel

No need to apologize!

comment:6 Changed 12 years ago by Andrey Novoseltsev

Status: needs_reviewneeds_work

I am still getting an error, although a different one. I am not sure if it is related since I didn't have a pdf version before. Working...

comment:7 Changed 12 years ago by Andrey Novoseltsev

Status: needs_workneeds_review

OK, looks like a false alarm. I have done the following:

  • Removed doc/output in a sage-4.5.1 installation.
  • Built PDF-documentation without any patches applied.
  • Applied all merged toric patches and the patch on this ticket.
  • Build PDF-documentation again. Is seems to be OK in the sense that I got back to the shell prompt, there is a big PDF file in output, and I can see the modified example there just fine.

Please test it with 4.5.2.alpha0.

comment:8 Changed 12 years ago by John Palmieri

Reviewers: John Palmieri
Status: needs_reviewpositive_review

Looks good to me. PDF builds successfully, output looks fine.

comment:9 Changed 12 years ago by Dan Drake

Merged in: sage-4.5.2.alpha1
Resolution: fixed
Status: positive_reviewclosed
Note: See TracTickets for help on using tickets.