Opened 10 years ago

Closed 10 years ago

#9561 closed defect (fixed)

Docbuild warnings caused by #9219

Reported by: mpatel Owned by: mvngu
Priority: blocker Milestone: sage-4.5.2
Component: documentation Keywords:
Cc: kcrisman, mvngu Merged in: sage-4.5.2.alpha1
Authors: Karl-Dieter Crisman Reviewers: John Palmieri
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The forthcoming 4.5.2.alpha0 includes #9219, which appears to cause the following docbuild warnings:

docstring of sage.stats.hmm.chmm.GaussianHiddenMarkovModel:14: (WARNING/2) Literal block expected; none found.
docstring of sage.stats.hmm.chmm.GaussianHiddenMarkovModel.viterbi:20: (WARNING/2) Literal block expected; none found.
docstring of sage.stats.hmm.distributions.Distribution.prob:13: (WARNING/2) Literal block expected; none found.
docstring of sage.stats.hmm.distributions.Distribution.sample:14: (WARNING/2) Literal block expected; none found.

Attachments (1)

trac_9561-stats-rst-warnings.patch (1.4 KB) - added by kcrisman 10 years ago.
Based on 4.5.1 plus relevant patches

Download all attachments as: .zip

Change History (5)

comment:1 Changed 10 years ago by kcrisman

This was caused by someone getting too excited about

EXAMPLES::

which does indeed often introduce actual examples, but now is more likely to have more text before the code itself. Should be very easy review.

Changed 10 years ago by kcrisman

Based on 4.5.1 plus relevant patches

comment:2 Changed 10 years ago by kcrisman

  • Authors set to Karl-Dieter Crisman
  • Status changed from new to needs_review

Either do 4.5.1 and patches from #9218 and #9219, or base on 4.5.2.alpha0. This should remove the warnings.

comment:3 Changed 10 years ago by jhpalmieri

  • Reviewers set to John Palmieri
  • Status changed from needs_review to positive_review

comment:4 Changed 10 years ago by ddrake

  • Merged in set to sage-4.5.2.alpha1
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.