Opened 9 years ago

Closed 7 years ago

#9547 closed defect (duplicate)

x * Infinity assumes that x is positive

Reported by: fredrik.johansson Owned by: burcin
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: kcrisman Merged in:
Authors: Reviewers: Burcin Erocal, Volker Braun
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage: var('x') * Infinity
+Infinity

This is not right; x could represent something non-positive.

Change History (13)

comment:1 Changed 8 years ago by tscrim

Likely the solution will be related with #11506.

comment:2 Changed 8 years ago by burcin

  • Authors set to Volker Braun
  • Component changed from algebra to symbolics
  • Milestone set to sage-5.1
  • Owner changed from AlexGhitza to burcin
  • Reviewers set to Burcin Erocal

This is fixed by #12950. There is a doctest on line 2429 of sage/symbolic/expression.pyx. We should close this ticket when that is merged.

comment:3 Changed 8 years ago by kcrisman

  • Cc kcrisman added

comment:4 Changed 7 years ago by burcin

  • Milestone changed from sage-5.1 to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

comment:5 Changed 7 years ago by burcin

  • Status changed from needs_review to positive_review

comment:6 follow-up: Changed 7 years ago by kcrisman

  • Milestone changed from sage-duplicate/invalid/wontfix to sage-5.2

Patch is at #12950, but still a valid ticket; that was a meta-ticket for the Pynac upgrade.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 7 years ago by jdemeyer

Replying to kcrisman:

Patch is at #12950, but still a valid ticket; that was a meta-ticket for the Pynac upgrade.

Same question as #1861: why doesn't this count as duplicate/invalid/wontfix?

comment:8 in reply to: ↑ 7 Changed 7 years ago by kcrisman

Patch is at #12950, but still a valid ticket; that was a meta-ticket for the Pynac upgrade.

Same question as #1861: why doesn't this count as duplicate/invalid/wontfix?

In my opinion (only?), tickets that are closed by metatickets are not duplicates. It seems better to me (only?) to make it clear that work went into all of the issues we close, instead of making it seem like we have hundreds of duplicates that people open. We already do have enough duplicates as it is :)

And we certainly fixed it, so it's not "wontfix", and it's not invalid either, or at least wasn't before #12950, which however, explicitly refers to this ticket - it's not like some other change in #12950 made this invalid, which does sometimes happen.

comment:9 follow-up: Changed 7 years ago by jdemeyer

If the issue is fixed by a different ticket, then this ticket should be either a "duplicate" or a "worksforme".

Has a doctest been added for this? If not, one could consider needs_work.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 7 years ago by kcrisman

If the issue is fixed by a different ticket, then this ticket should be either a "duplicate" or a "worksforme".

I simply disagree. So you are saying that, hypothetically, a gigantic metaticket for foo.spkg that bundles fifty changes, all of which are doctested by some huge patch at that ticket, means all the others are duplicates? That seems to denigrate the hard work that went into each of those other tickets. Although the people currently working on these particular tickets are not counting on this material for promotion, that is certainly a future possibility, as standards evolve, especially at less research-focused institutions.

Has a doctest been added for this? If not, one could consider needs_work.

Yes, it is at #12950.

comment:11 in reply to: ↑ 10 ; follow-up: Changed 7 years ago by jdemeyer

Replying to kcrisman:

If the issue is fixed by a different ticket, then this ticket should be either a "duplicate" or a "worksforme".

I simply disagree. So you are saying that, hypothetically, a gigantic metaticket for foo.spkg that bundles fifty changes, all of which are doctested by some huge patch at that ticket, means all the others are duplicates? That seems to denigrate the hard work that went into each of those other tickets. Although the people currently working on these particular tickets are not counting on this material for promotion, that is certainly a future possibility, as standards evolve, especially at less research-focused institutions.

You could give credit to those people on the other gigantic metaticket.

On this particular ticket here, I don't see any work done, so I would simply close it as duplicate.

comment:12 in reply to: ↑ 11 Changed 7 years ago by kcrisman

  • Authors Volker Braun deleted
  • Milestone changed from sage-5.2 to sage-duplicate/invalid/wontfix
  • Reviewers changed from Burcin Erocal to Burcin Erocal, Volker Braun

You could give credit to those people on the other gigantic metaticket.

Which Burcin did. The point was that although a ticket isn't a great measure of work, we don't have to make it an even worse measure.

On this particular ticket here, I don't see any work done, so I would simply close it as duplicate.

Well, I was going by the fact that someone else filled in author and reviewer fields and the work "just happened" to be there; see also the discussion at #12950. But if you insist, I suppose I've engaged in enough bikeshedding for one day.

comment:13 Changed 7 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.