Opened 9 years ago

Last modified 9 years ago

#9533 closed enhancement

Update GSL to the latest upstream release — at Initial Version

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-4.5.3
Component: packages: standard Keywords:
Cc: leif, mpatel Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

The version of the GNU Scientific Library (GSL) in Sage is 1.10, which is almost 3 years old. The latest, 1.14 was released about 4 months ago.

There is also a large number of bugs in the spkg-check and spkg-install files

  • spkg-check did not exit with a non-zero error code if the make check failed. It did however report the error, but it is highly likely to be missed in a large log file. This issue was reported at #9531, so that ticket can be closed when this one is closed.
  • spkg-install did not exit if configure failed to configure properly. Again the error was reported.
  • spkg-install did not exit if make failed to build GSL correctly. Again the error was reported.
  • spkg-install did not exit if make install failed to install GSL properly. Again the error was reported.
  • The self-tests were failing on some platforms, due to the fact /bin/rm: cannot remove `libtoolT. This was also true of the latest version, but exporting RM to "rm -f" solved that, as discussed at solution for libtoolT error

Change History (0)

Note: See TracTickets for help on using tickets.