Opened 12 years ago

Closed 12 years ago

#9514 closed defect (fixed)

sage/symbolic/random_tests.py wrongly depends on order of dict.values()

Reported by: cwitty Owned by: cwitty
Priority: major Milestone: sage-4.5.2
Component: symbolics Keywords:
Cc: Merged in: sage-4.5.2.alpha0
Authors: Carl Witty Reviewers: Andrey Novoseltsev
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

The variable sage.symbolic.random_tests.full_functions is ordered in the same order as the .values() method on a dict, which is not necessarily reproducible. (I'm a little curious as to why the order in fact does seem to be reproducible, across multiple platforms, etc., but changes with the addition of seemingly unrelated code -- but not curious enough to investigate.)

Anyway, the current code is clearly wrong. I'll have a fix in a few minutes.

This should fix the strange random_tests.py doctest issue from #8988, and possibly reduce the churn in the random_tests doctest results.

Attachments (1)

trac_9514-random-tests-sort-functions.patch (4.1 KB) - added by cwitty 12 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 12 years ago by cwitty

  • Authors set to Carl Witty
  • Status changed from new to needs_review

This patch fixes the problem, and also seems to fix the random_tests.py problem with #8988 (as expected).

comment:2 Changed 12 years ago by novoselt

  • Reviewers set to Andrey Novoseltsev
  • Status changed from needs_review to positive_review

Works for me and removes the necessity of interfering in #8988.

comment:3 Changed 12 years ago by mpatel

  • Merged in set to sage-4.5.2.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.