Opened 11 years ago

Last modified 7 years ago

#9465 closed enhancement

Update to FriCAS 1.1.0 — at Version 13

Reported by: hemmecke Owned by: AlexGhitza
Priority: major Milestone: sage-6.4
Component: packages: experimental Keywords: fricas
Cc: hemmecke, rws Merged in:
Authors: Ralf Hemmecke Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by chapoton)

The earlier upgrade is in #9354

Also look at #6517 for more information.

http://sage.math.washington.edu/home/hemmecke/pub/fricas-1.1.0.spkg

http://sage.math.washington.edu/home/hemmecke/pub/fricasaldor-1.1.0.spkg

fricasaldor might not properly work on 64 bit machines or might not work at all.

Link to project: http://sourceforge.net/projects/fricas/

Change History (13)

comment:1 Changed 11 years ago by hemmecke

  • Cc hemmecke added
  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 11 years ago by AlexGhitza

  • Component changed from algebra to packages
  • Milestone set to sage-5.0

comment:3 Changed 10 years ago by dimpase

Would you like to make an spkg with current Fricas? I'll make sure to review it, etc. Thanks!

comment:4 Changed 10 years ago by dimpase

  • Status changed from needs_review to needs_work

for the record, fricas-1.0.9 spkg fails to install in Sage 4.8 on x86_64 Linux (Debian).

comment:5 follow-up: Changed 10 years ago by hemmecke

Why are you considering 1.0.9? Above you find a link to 1.1.0. and FriCAS progressed to 1.1.5.

However, in 1.1.5 the aldor-interface is broken. It's already fixed in trunk, but I tend to wait till 1.1.6 is released in order to produce a new spkg.

Furthermore, quickly browsing over my spkg generation scripts, tells me, that I will have to fix some small issues.

BTW, is it still required that FriCAS for Sage must use ECL and not SBCL?

Ralf

comment:6 in reply to: ↑ 5 Changed 10 years ago by dimpase

Replying to hemmecke:

Why are you considering 1.0.9? Above you find a link to 1.1.0. and FriCAS progressed to 1.1.5.

I was just pointing out that an upgrade is needed badly.

However, in 1.1.5 the aldor-interface is broken. It's already fixed in trunk, but I tend to wait till 1.1.6 is released in order to produce a new spkg.

Furthermore, quickly browsing over my spkg generation scripts, tells me, that I will have to fix some small issues.

BTW, is it still required that FriCAS for Sage must use ECL and not SBCL?

Was it ever required? I guess it was never assumed that SBCL is installed on the system, so by default FriCAS can fall back on ECL provided by Sage. (This would need a trivial adjustment of the spkg-install, I suppose).

On the other hand a fast interface to FriCAS would need an embeddable Lisp, and ECL fits this bill.

Dima

Ralf

comment:7 Changed 8 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:8 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:9 Changed 8 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:10 Changed 7 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:11 Changed 7 years ago by jdemeyer

  • Component changed from packages: standard to packages: experimental

comment:12 Changed 7 years ago by chapoton

  • Description modified (diff)

comment:13 Changed 7 years ago by chapoton

  • Description modified (diff)
Note: See TracTickets for help on using tickets.