Opened 11 years ago

Closed 11 years ago

#9464 closed defect (duplicate)

R depends on Fortran, but has no such dependancy in spkg/standard/deps

Reported by: drkirkby Owned by: GeorgSWeber
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: rlm, jhpalmieri, mpatel Merged in:
Authors: David Kirkby Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In the sage-4.5.alpha4 code, the $SAGE_ROOT/spkg/standard/deps file has this entry for R:

$(INST)/$(R): $(BASE) $(INST)/$(PYTHON) $(INST)/$(ATLAS) $(INST)/$(ICONV)
        $(INSTALL) "$(SAGE_SPKG) $(R) 2>&1" "tee -a $(SAGE_LOGS)/$(R).log"

Note, there is no Fortran dependency listed, yet R does have Fortran files:

drkirkby@hawk:~/sage-4.5.alpha4/spkg/standard$ find r-2.10.1.p2 -name '*.f'
r-2.10.1.p2/src/src/library/stats/src/stxwx.f
r-2.10.1.p2/src/src/library/stats/src/sgram.f
r-2.10.1.p2/src/src/library/stats/src/bsplvd.f
r-2.10.1.p2/src/src/library/stats/src/stl.f
r-2.10.1.p2/src/src/library/stats/src/hclust.f
r-2.10.1.p2/src/src/library/stats/src/sslvrg.f
r-2.10.1.p2/src/src/library/stats/src/qsbart.f
r-2.10.1.p2/src/src/library/stats/src/bvalue.f
r-2.10.1.p2/src/src/library/stats/src/loessf.f
r-2.10.1.p2/src/src/library/stats/src/lminfl.f
r-2.10.1.p2/src/src/library/stats/src/kmns.f
r-2.10.1.p2/src/src/library/stats/src/eureka.f
r-2.10.1.p2/src/src/library/stats/src/sinerp.f
r-2.10.1.p2/src/src/library/stats/src/bvalus.f
r-2.10.1.p2/src/src/library/stats/src/ppr.f
r-2.10.1.p2/src/src/library/stats/src/portsrc.f
r-2.10.1.p2/src/src/appl/dchdc.f
r-2.10.1.p2/src/src/appl/chol.f
r-2.10.1.p2/src/src/appl/dqrsl.f
r-2.10.1.p2/src/src/appl/dqrdc2.f
r-2.10.1.p2/src/src/appl/eigen.f
r-2.10.1.p2/src/src/appl/dpoco.f
r-2.10.1.p2/src/src/appl/dposl.f
r-2.10.1.p2/src/src/appl/dpbfa.f
r-2.10.1.p2/src/src/appl/dtrco.f
r-2.10.1.p2/src/src/appl/dtrsl.f
r-2.10.1.p2/src/src/appl/ch2inv.f
r-2.10.1.p2/src/src/appl/dpofa.f
r-2.10.1.p2/src/src/appl/dqrutl.f
r-2.10.1.p2/src/src/appl/dqrdc.f
r-2.10.1.p2/src/src/appl/dpbsl.f
r-2.10.1.p2/src/src/appl/dpodi.f
r-2.10.1.p2/src/src/appl/dqrls.f
r-2.10.1.p2/src/src/appl/dsvdc.f
r-2.10.1.p2/src/src/modules/lapack/dlapack4.f
r-2.10.1.p2/src/src/modules/lapack/vecLibg95f.f
r-2.10.1.p2/src/src/modules/lapack/dlapack3.f
r-2.10.1.p2/src/src/modules/lapack/dlapack2.f
etc

I'll upload a patch and deps file

Dave

Attachments (2)

deps (18.1 KB) - added by drkirkby 11 years ago.
$SAGE_ROOT/spkg/standard/deps to force Fortran to build before R
deps.diff (503 bytes) - added by drkirkby 11 years ago.
Diff between $SAGE_ROOT/spkg/standard/deps and that is sage-4.5.alpha4

Download all attachments as: .zip

Change History (9)

comment:1 Changed 11 years ago by rlm

  • Priority changed from major to blocker

This looks like the cause of #9435

Changed 11 years ago by drkirkby

$SAGE_ROOT/spkg/standard/deps to force Fortran to build before R

Changed 11 years ago by drkirkby

Diff between $SAGE_ROOT/spkg/standard/deps and that is sage-4.5.alpha4

comment:2 follow-up: Changed 11 years ago by jhpalmieri

This change to deps seems fine -- making the dependencies explicit seems like a good idea -- but note that fortran is a dependency of lapack, lapack is a dependency of atlas, and atlas is a dependency of R. So fortran should always get installed before R even without this change. Have you seen otherwise?

comment:3 in reply to: ↑ 2 Changed 11 years ago by drkirkby

  • Authors set to David Kirkby
  • Status changed from new to needs_review

Replying to jhpalmieri:

This change to deps seems fine -- making the dependencies explicit seems like a good idea -- but note that fortran is a dependency of lapack, lapack is a dependency of atlas, and atlas is a dependency of R. So fortran should always get installed before R even without this change. Have you seen otherwise?

I've personally not seen a problem.

I must admit I did not look carefully to see the Fortran/LAPACK/ATLAS/R dependency. But Robert thought it was the cause of an OS X problem (see #9435), so upgraded this ticket to blocker. I think you have rather dashed that hope however!

Dave

comment:4 Changed 11 years ago by rlm

  • Priority changed from blocker to minor

comment:5 Changed 11 years ago by leif

This change is now incorporated in #9761, which already has positive review, so this ticket can be closed as duplicate.

Mitesh, that's your job... ;-)

comment:6 Changed 11 years ago by mpatel

  • Status changed from needs_review to positive_review

I'm changing the status to "positive review," so that the release mixer/masher/manager/monster will see it at report {11} or {32} and close this ticket as a "duplicate" after merging #9761.

comment:7 Changed 11 years ago by mpatel

  • Milestone changed from sage-4.5.3 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.