Opened 11 years ago

Closed 11 years ago

#9458 closed defect (duplicate)

Bug with variable names in solve()

Reported by: tastalian Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords: var solve name factorial
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Some variable names yield strange behavior with the solve() function. Here is an example:

----------------------------------------------------------------------
| Sage Version 4.4.2, Release Date: 2010-05-19                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
sage: var('d2 d3 x')
(d2, d3, x)
sage: solve((d2+d3)*x==1, x)
[x == factorial(2*k + 6*n)/(d3*factorial(2*k + 6*n) + factorial(k + 3*n - 1))]

These factorials are strange. They don't occur with other variable names, e.g.,

sage: var('y1 y2 x')
(y1, y2, x)
sage: solve((y1+y2)*x==1, x)
[x == (1/(y1 + y2))]

Documentation for solve() does not mention reserved variable names.

Change History (1)

comment:1 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.5 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed

This is basically a duplicate of #8734.

Note: See TracTickets for help on using tickets.