Opened 11 years ago

Closed 10 years ago

#9414 closed defect (duplicate)

make the rational number field consistent with other number fields

Reported by: rkirov Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: number field, rationals
Cc: Merged in:
Authors: Reviewers: Maarten Derickx
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Currently QQ behaves different than a generic number field. This forces number theory functions to treat QQ separately, which is inconvenient.

K = QQ
I = K.ideal(7)

This creates ideal that does not have the functions I.denominator, I.numerator, I.prime_ideals() ... which a fractional ideal in a number field should have

K.<a> = NumberField(x^2+2)
I = K.ideal(7)

Similarly, QQ.places() is not implemented; it should return the one infinite place for Q. Although there seems to be QQ.embeddings().

QQ.places()

Change History (5)

comment:1 Changed 11 years ago by rkirov

  • Summary changed from make the rational number field, consistent with other number fields to make the rational number field consistent with other number fields

comment:2 Changed 10 years ago by mderickx

  • Status changed from new to needs_review

This is a duplicate of #7596. I'm putting it as positive review so that someone with the right abilities will see it an close this as duplicate ticket.

comment:3 Changed 10 years ago by mderickx

  • Status changed from needs_review to positive_review

comment:4 Changed 10 years ago by mderickx

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix

comment:5 Changed 10 years ago by jdemeyer

  • Resolution set to duplicate
  • Reviewers set to Maarten Derickx
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.