Opened 11 years ago

Closed 9 years ago

#9408 closed defect (duplicate)

relativize in number fields is broken

Reported by: lftabera Owned by: davidloeffler
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: number fields Keywords: relativize
Cc: Merged in:
Authors: Reviewers: Luis Felipe Tabera Alonso
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: #252 Stopgaps:

Status badges

Description (last modified by jdemeyer)

Does not work due to denominators:

sage: K.<a> = NumberField(x^4-4*x^3+12*x^2-16*x+8)
sage: L.<u,v> = K.relativize(3*a**3 - 9*a**2 + 24*a -16)  # OK
sage: L2.<u2,v2> = K.relativize((3/4)*a**3 - (9/4)*a**2 + 6*a -4)

Simpler example:

sage: L.<a,b> = QQ[i].relativize(1) # OK
sage: L.<a,b> = QQ[i].relativize(1/2)
...
TypeError: Unable to coerce number field defined by non-integral polynomial to PARI.

This is in some sense a duplicate of #252.

Change History (4)

comment:1 Changed 11 years ago by lftabera

  • Status changed from new to needs_info

This ticket should be closed as duplicate of #252

comment:2 Changed 10 years ago by lftabera

  • Status changed from needs_info to needs_review

comment:3 Changed 9 years ago by jdemeyer

  • Dependencies set to #252
  • Description modified (diff)
  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix
  • Reviewers set to Luis Felipe Tabera Alonso
  • Status changed from needs_review to positive_review

comment:4 Changed 9 years ago by jdemeyer

  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.