Opened 13 years ago

Closed 13 years ago

#932 closed enhancement (duplicate)

upgrade lcalc in sage

Reported by: was Owned by: mabshoff
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by mabshoff)

Hi William. Before you go ahead and make a big official table like that,
you should upgrade to the latest lcalc. I'll be releasing that in a few
days. It has a more efficient zero finding routine and also gets rid of
annoying warning message that sometimes appears when it ought not to...
the message might interfere with the preparation of your table. Also,
currently not all digits outputed are guaranteed. For low conductor I
don't think that will be an issue, but as the conductor increases
that will be a bit relevant.

I'm currently implementing something to verify the precision and adjust the
output accordingly.

It also has other improvements, though not relevant for the table you
mention.

Mike

Change History (8)

comment:2 Changed 13 years ago by mabshoff

I am not sure if this is going to make it for 2.8.8, but we ca at least try.

Cheers,

Michael

comment:1 Changed 13 years ago by mabshoff

  • Description modified (diff)

comment:2 Changed 13 years ago by was

  • Milestone changed from sage-2.8.8 to sage-2.8.9

comment:3 Changed 13 years ago by mabshoff

  • Milestone changed from sage-2.8.9 to sage-2.8.10

comment:4 Changed 13 years ago by mabshoff

Mike Rubinstein says:

Dear Colleagues,

I've released a new version of lcalc.

This release fixes some bugs (so please update), has improvements to
some of the key
routines, especially for higher degree L-functions (i.e. deg >=3, and
also for Maass forms),
and better handling of output precision.

The code can be downloaded from:
http://pmmac03.math.uwaterloo.ca/~mrubinst/L_function_public/CODE/

Please email me any bugs you notice.

Thanks,
Mike

Cheers,

Michael

comment:5 Changed 13 years ago by mabshoff

Hmm, see also #1626 and #449.

Cheers,

Michael

comment:6 Changed 13 years ago by mabshoff

  • Owner changed from was to mabshoff
  • Status changed from new to assigned

comment:7 Changed 13 years ago by mabshoff

  • Milestone changed from sage-3.0 to sage-duplicate/invalid
  • Resolution set to duplicate
  • Status changed from assigned to closed

This is a dupe of #1626

Note: See TracTickets for help on using tickets.