Opened 9 years ago

Closed 4 years ago

Last modified 4 years ago

#9288 closed enhancement (duplicate)

Implement complex reflection groups

Reported by: nthiery Owned by: AlexGhitza
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: algebra Keywords:
Cc: sage-combinat Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

    sage: ComplexReflectionGroup(1,1,5)
    WeylGroup of type A4

    sage: W = ComplexReflectionGroup(33); W
    returns the 33 rd exceptional group

    sage: W.diagram()

Note: the current implementation of Coxeter groups is in principle designed to open the door for such generalizations; see in particular the WeylGroup? code for Coxeter groups implemented in terms of matrix groups.

Change History (4)

comment:1 Changed 6 years ago by chapoton

See #11187

comment:2 Changed 4 years ago by chapoton

  • Milestone changed from sage-wishlist to sage-duplicate/invalid/wontfix
  • Status changed from new to needs_review

Duplicate of #11187, can be closed.

comment:3 Changed 4 years ago by stumpc5

  • Resolution set to duplicate
  • Status changed from needs_review to closed

comment:4 Changed 4 years ago by chapoton

hmm, I think closed is only for the release manager... but no way back..

Note: See TracTickets for help on using tickets.