Changes between Version 107 and Version 115 of Ticket #9238


Ignore:
Timestamp:
03/23/11 20:54:26 (10 years ago)
Author:
kcrisman
Comment:

After #9232, apply trac_9238_interactive_js.patch and trac_9238-add-help.patch.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #9238 – Description

    v107 v115  
    11Ready for testing, but requires two steps.  Starting with a clean Sage 4.6.2: [[BR]]
    22
    3  1. patch for Jmol at the command line. See [http://trac.sagemath.org/sage_trac/ticket/9232 #9232].
    4  1. Apply the patch trac_9238_interactive_js.patch in attachments (below).
     3 1. Patch and spkg for Jmol at the command line. See [http://trac.sagemath.org/sage_trac/ticket/9232 #9232].
     4 1. Apply [attachment:trac_9238_interactive_js.patch] and [attachment:trac_9238-add-help.patch].
    55
    66I have addressed the following issues (let me know if I've missed anything): [[BR]]
     
    1313Happy testing and thank you to those who do test!
    1414
    15 You can try an older version without going through patching by following the instructions below (the newer patched version is better).
    1615
    17 If you are using Sage > 4.5 you can get the latest .spkg here:
    18 
    19 {{{
    20 ./sage -f http://www.uwosh.edu/faculty_staff/gutow/Jmol_for_SageNoteBook-1.1.4.spkg
    21 }}}
    22 {{{
    23 (or sage -f http://www.uwosh.edu/faculty_staff/gutow/Jmol_for_SageNoteBook-1.1.4.spkg)
    24 }}}
    25 If you are using <= Sage 4.5  the below should still work, but is outdated.  The newer package above will not work on older Sage because of changes in the notebook architecture.
    26 
    27 To test, do:
    28 
    29 {{{
    30 sage -f http://www.uwosh.edu/faculty_staff/gutow/Jmol_for_SageNoteBook-1.1.2.spkg
    31 }}}
    32 or
    33 
    34 {{{
    35 ./sage -f http://www.uwosh.edu/faculty_staff/gutow/Jmol_for_SageNoteBook-1.1.2.spkg
    36 }}}
    37 depending on your command line syntax.
    38 
    39 This will change the Jmol files, jmol_lib.js and notebook_lib.js (current as of Sage 4.4.3), so you might want to do it in a test Sage installation.
     16----
     17Older description:
    4018
    4119Adds the following features to the notebook: