Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#9229 closed defect (duplicate)

Bring doctests for databases/cremona.py up to 100% (from 42% (17 of 40) )

Reported by: cremona Owned by: cremona
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

devel/sage-main/sage/databases/cremona.py
ERROR: Please add a `TestSuite(s).run()` doctest.
SCORE devel/sage-main/sage/databases/cremona.py: 42% (17 of 40)

Missing documentation:
* _init(self, ftpdata):
* __repr__(self):
* CremonaDatabase():


Missing doctests:
* rebuild(data_tgz, largest_conductor, decompress=True):
* __init__(self, read_only=True):
* __iter__(self):
* __getitem__(self, N):
* __repr__(self):
* allbsd(self, N):
* allcurves(self, N):
* allgens(self, N):
* degphi(self, N):
* elliptic_curve_from_ainvs(self, N, ainvs):
* elliptic_curve(self, label):
* iter(self, conductors):
* isogeny_classes(self, conductor):
* isogeny_class(self, label):
* list(self, conductors):
* _init_allcurves(self, ftpdata, largest_conductor=0):
* _init_degphi(self, ftpdata, largest_conductor=0):
* _init_allbsd(self, ftpdata, largest_conductor=0):
* _init_allgens(self, ftpdata, largest_conductor=0):
* __init__(self, read_only=True):

Change History (3)

comment:1 Changed 11 years ago by cremona

  • Priority changed from major to minor

This is a duplicate of #9223 and should be deleted.

comment:2 Changed 11 years ago by drkirkby

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 11 years ago by mvngu

  • Milestone changed from sage-5.0 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.