Opened 8 years ago

Closed 5 years ago

#9196 closed enhancement (duplicate)

Update ATLAS to the latest upstream souce

Reported by: drkirkby Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: packages: standard Keywords:
Cc: Merged in:
Authors: Reviewers: Jeroen Demeyer
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Change History (5)

comment:1 Changed 8 years ago by AlexGhitza

  • Component changed from algebra to packages
  • Owner changed from AlexGhitza to tbd

comment:2 Changed 8 years ago by drkirkby

Sorry Alex for this.

It is annoying that the default is "algebra". It would be better if there was no default, and someone had to chose something.

Dave

comment:3 follow-up: Changed 8 years ago by AlexGhitza

Not a problem, I was just doing some cleaning. The simplest solution might be to add a new component called "aaa-misc" that would catch the tickets where the component has not been set. Then once in a while we can sift through that and classify tickets, without "algebra" getting polluted.

comment:4 in reply to: ↑ 3 Changed 8 years ago by drkirkby

Replying to AlexGhitza:

Not a problem, I was just doing some cleaning. The simplest solution might be to add a new component called "aaa-misc" that would catch the tickets where the component has not been set. Then once in a while we can sift through that and classify tickets, without "algebra" getting polluted.

I imagine you must get this quite a lot, which is a bit of a waste of your time. To be honest, I might have left this at "algebra" deliberately, as ATLAS is an acronym for "Automatically Tuned Linear Algebra System". But I know I do occasionally leave things at "algebra" by mistake.

As a non-mathematician, I often have difficulty in knowing what best to classify something under.

It's arguable if this should go under "linear algebra" rather than "packages". I really don't know half the time. To me, "packages" seems a bit too wide.

I think it would be useful if there were tick boxes, and one could tick a few. The other one to get ATLAS working on HP-UX (#9815) could reasonably be in "linear algebra", "packages" and "porting".

Dave

comment:5 Changed 5 years ago by jdemeyer

  • Milestone changed from sage-5.10 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Reviewers set to Jeroen Demeyer
  • Status changed from new to closed

Duplicate of #10508.

Note: See TracTickets for help on using tickets.