Opened 10 years ago

Closed 7 years ago

#9176 closed defect (invalid)

cygwin: various heegner_index errors involving interval arithmetic on cygwin

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords: cygwin
Cc: kcrisman, dimpase Merged in:
Authors: Reviewers: Jean-Pierre Flori, Dmitrii Pasechnik, Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage -t  "devel/sage/sage/schemes/elliptic_curves/heegner.py"
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/heegner.py", line 6380:
    sage: E.heegner_index(-7)
Expected:
    1.00000?
Got:
    1
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/heegner.py", line 6410:
    sage: I = E.heegner_index(-8); I
Expected:
    1.50000?
Got:
    1
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/heegner.py", line 6412:
    sage: 2*I
Expected:
    3.0000?
Got:
    2
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/heegner.py", line 6546:
    sage: E.heegner_index_bound()
Expected:
    ([2], -7)
Got:
    ([], -7)
**********************************************************************
2 items had failures:
   3 of  15 in __main__.example_229
   1 of   4 in __main__.example_231
***Test Failed*** 4 failures.
For whitespace errors, see the file /home/wstein/.sage//tmp/.doctest_heegner.py

Change History (26)

comment:1 Changed 8 years ago by kcrisman

This file passed doctests in a build of mine on XP.

comment:2 Changed 8 years ago by kcrisman

But trying the first example by hand leads to a segfault (presumably related to the segfault currently bedeveling Cygwin startup, see #11551).

That is weird. Is it possible that a silent segfault makes a doctest think it passed?

comment:3 follow-up: Changed 7 years ago by jpflori

Got lots of failures, apparently because of forking issues, I'll try a rebase.

comment:4 Changed 7 years ago by jpflori

Also lots of MemoryError? for PARI trying to allocate memory.

comment:5 in reply to: ↑ 3 Changed 7 years ago by kcrisman

Got lots of failures, apparently because of forking issues, I'll try a rebase.

Glad at least one of the forking issues I had cropped up for you :-) Even if it does work on a rebase, don't forget to try by hand as well.

comment:6 Changed 7 years ago by jpflori

And indeed inside "./sage -gp" I cannot allocatemem(512000000), but only 256000000, not sure why though.

comment:7 Changed 7 years ago by jpflori

I think I only have one forking issue (among 202 failing tests) caused by ecl which I rebuilt in the end (and potentially did not rebase after that).

comment:8 Changed 7 years ago by jpflori

And I guess it is http://cygwin.com/cygwin-ug-net/setup-maxmem.html so was expected.

So I'm left with the one forking issue :)

comment:9 Changed 7 years ago by jpflori

Ok I still get the forking issue after rebasing :( the only solution might be to get a clean install at once (I rebuilt ECL p1 spkg and dependencies after having installed all Sage with the p0).

Not sure how to let Cygwin increase the mx mem used, using peflags on python tells me it could not open the file...

comment:10 Changed 7 years ago by jpflori

The max mem I can allocate is 502333407 and all the hacks I tried in the registry seem to have no (good or bad) effect.

comment:11 Changed 7 years ago by jpflori

Ok, I manage to use peflags to modify --cygwin-heap but if I set it to 1024MB then I get forking errors...

comment:12 Changed 7 years ago by jpflori

I can set it to 600MB without forking errors and that is enough to let the tests pass. (And indeed the global variable heap_chunk_in_mb support has been removed in Cygwin 1.7.10, see http://cygwin.com/cygwin-ug-net/ov-new1.7.html.)

comment:13 follow-up: Changed 7 years ago by dimpase

  • Status changed from new to needs_review

I propose to close it (as won't fix/worksforme), as it works now.

comment:14 in reply to: ↑ 13 Changed 7 years ago by jpflori

  • Cc kcrisman dimpase added

Replying to dimpase:

I propose to close it (as won't fix/worksforme), as it works now.

Did you actually manage to run the test without hacking around with --cygwin-heap? I think we should at least add some doc somewhere to state that the tests are expected to fail with default max heap memory and how to modify that (e.g. use peflags and the global var is not supported anymore).

comment:15 Changed 7 years ago by jpflori

  • Status changed from needs_review to needs_info

comment:16 Changed 7 years ago by jpflori

  • Status changed from needs_info to needs_review

Anyway, I don't think we should deal with the peflags usage in another ticket as this was not the point of this ticket originally.

So lets close this one. Ill open a ticket for documenting usage of peflags shortly.

comment:17 Changed 7 years ago by jpflori

This is #14207.

comment:18 follow-up: Changed 7 years ago by kcrisman

Okay, I finally got this to doctest without forking errors, and mostly am seeing the same problem you are. I'm not going to bother messing around with Pari's memory because I don't know how to do that and you guys are on it. I do get a lot of extra failures

Expected:
    0
Got:
    32

which seems to be exactly one per example. Of course, there is no such doctest listed in the file, so this must be something in the framework.

comment:19 in reply to: ↑ 18 Changed 7 years ago by jpflori

Replying to kcrisman:

Okay, I finally got this to doctest without forking errors, and mostly am seeing the same problem you are. I'm not going to bother messing around with Pari's memory because I don't know how to do that and you guys are on it. I do get a lot of extra failures

Expected:
    0
Got:
    32

I guess these extra failures are mostly due to the fact a previous doctest needing too much memory for PARI failed.

which seems to be exactly one per example. Of course, there is no such doctest listed in the file, so this must be something in the framework.

comment:20 Changed 7 years ago by kcrisman

Sorry for not following up - so you agree with Dima that this is a pure memory issue, and so should be closed? Should we at least put a mention in the doc for this file that "if you are on a system with not much memory allocated (such as default Cygwin, but perhaps others like tablets or something) then there is this trick, see the verbiage added by #14207"?

comment:21 Changed 7 years ago by jpflori

  • Keywords cygwin added
  • Status changed from needs_review to positive_review

I do, lets close this one.

comment:22 Changed 7 years ago by jdemeyer

Please fill in Author/Reviewer?.

comment:23 Changed 7 years ago by jpflori

  • Authors set to Jean-Pierre Flori, Dmitrii Pasechnick, Karl-Dieter Crisman
  • Milestone changed from sage-5.9 to sage-duplicate/invalid/wontfix

comment:24 Changed 7 years ago by jpflori

  • Authors Jean-Pierre Flori, Dmitrii Pasechnick, Karl-Dieter Crisman deleted
  • Reviewers set to Jean-Pierre Flori, Dmitrii Pasechnick, Karl-Dieter Crisman

comment:25 Changed 7 years ago by jpflori

  • Reviewers changed from Jean-Pierre Flori, Dmitrii Pasechnick, Karl-Dieter Crisman to Jean-Pierre Flori, Dmitrii Pasechnik, Karl-Dieter Crisman

comment:26 Changed 7 years ago by jdemeyer

  • Resolution set to invalid
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.