Opened 10 years ago

Closed 7 years ago

#9173 closed defect (worksforme)

cygwin: BSD.py tests behave differently on cygwin, so need to be written to reflect that

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: jpflori, dimpase, kcrisman Merged in:
Authors: Reviewers: Jean-Pierre Flori
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage -t  "devel/sage/sage/schemes/elliptic_curves/BSD.py"   
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/BSD.py", line 174:
    sage: native_two_isogeny_descent_work(E, E.two_torsion_rank())
Expected:
    (1, 1, 0, 0, None)
Got:
    (0, 1, 0, 1, None)
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/BSD.py", line 391:
    sage: E.prove_BSD(verbosity=1, secs_hi=1)
Expected:
    p = 2: True by 2-descent
    Timeout stopped Heegner index computation...
    Proceeding to use heegner_index_bound instead.
    True for p not in {2, 3} by Kolyvagin.
    [3]
Got:
    p = 2: True by 2-descent
    Timeout stopped Heegner index computation...
    Proceeding to use heegner_index_bound instead.
    True for p not in {2, 3, 5} by Kolyvagin.
    True for p=5 by Stein-Wuthrich.
    [3]
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/schemes/elliptic_curves/BSD.py", line 426:
    sage: E.prove_BSD(verbosity=1)
Expected:
    p = 2: True by 2-descent
    Timeout stopped Heegner index computation...
    Proceeding to use heegner_index_bound instead.
    True for p not in {2} by Kolyvagin.
    []
Got:
    p = 2: True by 2-descent
    Timeout stopped Heegner index computation...
    Proceeding to use heegner_index_bound instead.
    True for p not in {2, 3, 5} by Kolyvagin.
    True for p=5 by Stein-Wuthrich.
    p = 3 may divide the Heegner index, for which only a bound was computed.
    ALERT: p = 3 left in Kolyvagin bound
        0 <= ord_p(#Sha) <= 2
        ord_p(#Sha_an) = 0
    [3]
**********************************************************************
2 items had failures:
   1 of   7 in __main__.example_4
   2 of  34 in __main__.example_6
***Test Failed*** 3 failures.

Change History (12)

comment:1 Changed 10 years ago by drkirkby

  • Cc mhansen added

The same is happening on Solaris 10 on all the SPARC boxes I have access to - see #9127 It appears to be a function of the speed of the computer, with timeouts occuring on slower hardware. I assume the overhead of Cygwin is causing this problem.

As such, I think this can probably be closed as a duplicate of #9127, which has positive review. You can try the patch there

http://trac.sagemath.org/sage_trac/raw-attachment/ticket/9127/trac_9127.patch

Dave

comment:2 Changed 10 years ago by drkirkby

  • Cc cremona added

On closer inspection, it looks like the issues you are getting on Cygwin are larger than those on Solaris, as I have not seen the

Expected:
    (1, 1, 0, 0, None)
Got:
    (0, 1, 0, 1, None)

error - only the ones due to timeouts.

Dave

comment:3 Changed 8 years ago by kcrisman

This doctest passed on a build of mine on XP. In fact, the only files in schemes/ that failed were two in the plane conics section, probably because of "I" not working.

comment:4 Changed 7 years ago by kcrisman

  • Cc jpflori added

I get lots of forking errors now, because it "can't start pari".

comment:5 follow-up: Changed 7 years ago by jpflori

And the test passes for me (64bits W7 + 5.6.rc0).

comment:6 in reply to: ↑ 5 ; follow-up: Changed 7 years ago by kcrisman

And the test passes for me (64bits W7 + 5.6.rc0).

Don't forget to try these by hand as well. In the past I've had failures only in the terminal.

comment:7 in reply to: ↑ 6 ; follow-up: Changed 7 years ago by jpflori

Replying to kcrisman:

And the test passes for me (64bits W7 + 5.6.rc0).

Don't forget to try these by hand as well. In the past I've had failures only in the terminal.

You mean copy/paste the doctests in an interactive Sage session? That's kind of boring isn't it? :)

comment:8 Changed 7 years ago by jpflori

I tested some random examples and some from te failing ones quoting in the ticket description and had no problems.

comment:9 in reply to: ↑ 7 Changed 7 years ago by kcrisman

And the test passes for me (64bits W7 + 5.6.rc0).

Don't forget to try these by hand as well. In the past I've had failures only in the terminal.

You mean copy/paste the doctests in an interactive Sage session? That's kind of boring isn't it? :)

Yes, you are right. But unfortunately I had some bad experiences with these Cygwin tests in the past so I figure I should ask - sorry :(

comment:10 Changed 7 years ago by jpflori

  • Cc dimpase kcrisman added; mhansen cremona removed
  • Status changed from new to needs_review

comment:11 Changed 7 years ago by jpflori

  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

No problems on another install, so let's close this one.

comment:12 Changed 7 years ago by jdemeyer

  • Resolution set to worksforme
  • Reviewers set to Jean-Pierre Flori
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.