Opened 10 years ago

Closed 7 years ago

#9171 closed defect (worksforme)

cygwin: Documentation not built, which causes test failures

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords:
Cc: jpflori Merged in:
Authors: Reviewers: Karl-Dieter Crisman, Jean-Pierre Flori
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

sage -t  "devel/sage/sage/misc/sagedoc.py"                  
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/misc/sagedoc.py", line 891:
    sage: len(search_doc('tree', interact=False).splitlines()) > 2000
Expected:
    True
Got:
    False
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/misc/sagedoc.py", line 496:
    sage: 'abvar/homology' in _search_src_or_doc('doc', 'homology', 'variety', interact=False)
Expected:
    True
Got:
    False

Change History (13)

comment:1 Changed 9 years ago by kcrisman

I usually get these errors if the documentation isn't built. Is that's what's going on here?

comment:2 Changed 8 years ago by kcrisman

I get the second failure, but not the first one, on a recent build on XP.

comment:3 Changed 8 years ago by kcrisman

  • Summary changed from cygwin: some test failures in sagedoc.py to cygwin: Documentation not built causes, which causes test failures

I'm getting these failures by hand, though. And I checked - the documentation is not automatically built. So let's change this title.

comment:4 Changed 7 years ago by kcrisman

  • Cc jpflori added

JP says that the doc does now build (since Maxima now works with #9167).

comment:5 Changed 7 years ago by kcrisman

  • Summary changed from cygwin: Documentation not built causes, which causes test failures to cygwin: Documentation not built, which causes test failures

comment:6 Changed 7 years ago by jpflori

Yup the doc built fine for me and the test passes. If you can reproduce that, let's close this ticket.

comment:7 Changed 7 years ago by kcrisman

This is really frustrating for me - I simply cannot build the doc, or (once again) even start Sage, even though it just was working a few days ago. All the usual can't map foo.dll to the same address stuff. I've rebased several times, no luck, though sometimes different files that can't map...

I'd like to try this again, though - yet another build from scratch, hopefully. There is no rush to close this, after all, as there is no patch or spkg required.

comment:8 Changed 7 years ago by jpflori

  • Status changed from new to needs_review

I once again built the doc succesfully, so let's close this one. I doubt XP/7 32bits/64bits will make any difference.

comment:9 Changed 7 years ago by kcrisman

No, I think you are right. Assuming one can get Sage to start reliably, this should now be okay.

comment:10 Changed 7 years ago by jpflori

  • Milestone changed from sage-5.7 to sage-duplicate/invalid/wontfix
  • Reviewers set to Karl-Dieter Crisman, Jean-Pierre Flori
  • Status changed from needs_review to positive_review

Ok, so I'm putting this as positive_review/wontfix

comment:11 Changed 7 years ago by kcrisman

I guess it would be worth confirming this doctest passes :) though I'm sure it will now.

comment:12 Changed 7 years ago by jpflori

It passed on my 5.5.rc0 and 5.6.rc0 'make ptest' and just did so on my 5.7.beta1.

comment:13 Changed 7 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.