Opened 10 years ago

Closed 7 years ago

#9168 closed defect (worksforme)

cygwin: ratpoints does not work correctly

Reported by: was Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: porting: Cygwin Keywords: cygwin
Cc: jpflori Merged in:
Authors: Reviewers: Karl-Dieter Crisman
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Some ratpoints tests fail on cygwin, e.g.:

sage -t  "devel/sage/sage/libs/ratpoints.pyx"               
**********************************************************************
File "/home/wstein/sage-4.4.3/devel/sage/sage/libs/ratpoints.pyx", line 57:
    sage: for x,y,z in ratpoints([1..6], 200):
       print -Integer(1)*y**Integer(2) + Integer(1)*z**Integer(6) + Integer(2)*x*z**Integer(5) + Integer(3)*x**Integer(2)*z**Integer(4) + Integer(4)*x**Integer(3)*z**Integer(3) + Integer(5)*x**Integer(4)*z**Integer(2) + Integer(6)*x**Integer(5)*z
Expected:
    0
    0
    0
    0
    0
    0
    0
Got:
    0
    0
    0

What happens when the same is done manually:

sage: from sage.libs.ratpoints import ratpoints
sage: 
sage: for x,y,z in ratpoints([1..6], 200):
....:     print -1*y^2 + 1*z^6 + 2*x*z^5 + 3*x^2*z^4 + 4*x^3*z^3 + 5*x^4*z^2 + 6*x^5*z
....:     
0
0
0

So the problem is simply that less points are found. Sounds pretty serious...

Change History (5)

comment:1 Changed 8 years ago by kcrisman

This files passes tests on a recent build on XP.

comment:2 Changed 8 years ago by kcrisman

But the same thing happens by hand. Why are all these tests passing on Cygwin?

comment:3 Changed 7 years ago by kcrisman

  • Cc jpflori added
  • Milestone changed from sage-5.6 to sage-duplicate/invalid/wontfix
  • Reviewers set to Karl-Dieter Crisman
  • Status changed from new to needs_review

This now passes, and when I do it by hand I do indeed get seven zeros. JP, if you can confirm this, then we can close this ticket as no longer valid.

comment:4 Changed 7 years ago by jpflori

  • Keywords cygwin added
  • Status changed from needs_review to positive_review

Works for me too.

comment:5 Changed 7 years ago by jdemeyer

  • Resolution set to worksforme
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.