Opened 11 years ago

Closed 10 years ago

#9154 closed defect (fixed)

boehm_gc (still, still) fails to build on Cygwin

Reported by: was Owned by: tbd
Priority: critical Milestone: sage-4.7.1
Component: packages: standard Keywords:
Cc: leif Merged in: sage-4.7.1.alpha2
Authors: Mike Hansen Reviewers: Dmitrii Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by dimpase)

This is a followup to #9067. Amazingly, the BoehmGC spkg: boehm_gc-7.1.p5.spkg in Sage 4.4.3 does not work.

Apply the spkg http://boxen.math.washington.edu/home/dima/packages/boehm_gc-7.1.p7.spkg.

Change History (14)

comment:1 Changed 11 years ago by drkirkby

Did it work?

Since libtool is used, all compiler warnings are dirrected to /dev/null. There's an option on libtool to enable the warnings, though I forget what it is.

comment:2 Changed 11 years ago by mhansen

  • Authors set to Mike Hansen
  • Status changed from new to needs_review

There is a new spkg at http://boxen.math.washington.edu/home/mhansen/boehm_gc-7.1.p7.spkg which worked for me on winxp2.

comment:3 Changed 11 years ago by leif

  • Cc leif added

comment:4 Changed 10 years ago by dimpase

  • Status changed from needs_review to positive_review

works for me with SAGE_CHECK=yes on Windows 7. It's a Cygwin-specific change. Positive review.

comment:5 Changed 10 years ago by jdemeyer

  • Description modified (diff)
  • Milestone changed from sage-4.7 to sage-4.7.1
  • Reviewers set to Dmitrii Pasechnik

comment:6 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.7.1.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed

comment:7 follow-up: Changed 10 years ago by jdemeyer

  • Merged in sage-4.7.1.alpha0 deleted
  • Resolution fixed deleted
  • Status changed from closed to new

SPKG.txt needs to be updated to mention this ticket.

comment:8 Changed 10 years ago by jdemeyer

  • Status changed from new to needs_review
  • Work issues set to SPKG.txt

comment:9 Changed 10 years ago by jdemeyer

  • Status changed from needs_review to needs_work

comment:10 in reply to: ↑ 7 Changed 10 years ago by dimpase

  • Description modified (diff)
  • Status changed from needs_work to positive_review

Replying to jdemeyer:

SPKG.txt needs to be updated to mention this ticket.

done.

comment:11 follow-up: Changed 10 years ago by jdemeyer

  • Status changed from positive_review to needs_work
  • Work issues changed from SPKG.txt to HTTP 404

Where is the spkg?

The requested URL /home/dima/boehm_gc-7.1.p7.spkg was not found on this server.

comment:12 in reply to: ↑ 11 Changed 10 years ago by dimpase

  • Description modified (diff)
  • Status changed from needs_work to positive_review

Replying to jdemeyer:

Where is the spkg?

The requested URL /home/dima/boehm_gc-7.1.p7.spkg was not found on this server.

Mea culpa. Fixed the URL.

comment:13 Changed 10 years ago by jdemeyer

  • Work issues HTTP 404 deleted

comment:14 Changed 10 years ago by jdemeyer

  • Merged in set to sage-4.7.1.alpha2
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.