Opened 10 years ago

Closed 10 years ago

#9147 closed enhancement (invalid)

[with patch, needs review] Make sage able to compile/link with --as-needed

Reported by: cschwan Owned by: tba
Priority: minor Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

With sage-on-gentoo it is possible to compile Sage with custom CFLAGS/LDFLAGS. One common LDFLAG on gentoo is "-Wl,--as-needed" which has some advantages when it comes to upgrading a program's dependencies (see http://www.gentoo.org/proj/en/qa/asneeded.xml for a good explanation).

The following patch is needed to enable Sage to be compiled with --as-needed; even if one does not do so the patch should not hurt.

Attachments (1)

sage-4.4.2-enable-as-needed.patch (926 bytes) - added by cschwan 10 years ago.

Download all attachments as: .zip

Change History (2)

Changed 10 years ago by cschwan

comment:1 Changed 10 years ago by mhansen

  • Milestone changed from sage-4.4.4 to sage-duplicate/invalid/wontfix
  • Resolution set to invalid
  • Status changed from new to closed

This is already handled by #8844.

Note: See TracTickets for help on using tickets.