Opened 10 years ago

Closed 10 years ago

#9145 closed enhancement (fixed)

Expand math symbols available in documentation, remove doc/common/macros.tex

Reported by: rbeezer Owned by: mvngu
Priority: minor Milestone: sage-4.4.4
Component: documentation Keywords:
Cc: jhpalmieri Merged in: sage-4.4.4.alpha0
Authors: Rob Beezer Reviewers: Minh Van Nguyen
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Attachments (1)

trac_9145_math_symbols_docs.patch (4.2 KB) - added by rbeezer 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by rbeezer

comment:1 Changed 10 years ago by rbeezer

  • Authors set to Rob Beezer
  • Cc jhpalmieri added
  • Status changed from new to needs_review

Patch removes doc/common/macros.tex, replaces amsfonts by amssymb in latex preamble string of doc/common/conf.py.

4.4.3.alpha3 HTMl and PDF documentation all build without halting when this patch is applied and a limited survey indicates they look good as well.

comment:2 Changed 10 years ago by mvngu

  • Reviewers set to Minh Van Nguyen
  • Status changed from needs_review to positive_review

Without the patch, when building the PDF version of the reference manual for Sage 4.4.3, I got:

! Undefined control sequence.
l.217693 ...als}(\mathrm{pos}_{i+1})]_{1 \leqslant 
                                                   i \leqslant n}$

Note that the HTML version built OK. With the patch, the PDF version built successfully on these machines:

  • sage.math, Ubuntu 8.04.4 LTS, with latex and pdflatex
  • bsd.math, Mac OS X 10.6.3, with latex and pdflatex

But failed on these machines:

  • eno.skynet, Fedora 12, no latex or pdflatex
  • rh.math, Ubuntu 10.04 LTS, no latex or pdflatex
  • rosemary.math, Red Hat Enterprise Linux Server 5.5, with latex and pdflatex, but I got the following error when building the PDF version:
    ! LaTeX Error: File `utf8x.def' not found.
    
    This also happens without the patch. The issue is more likely due to the LaTeX installation on rosemary.math.

As for doc/common/macros.tex, that file was during the days when Sage's documentation followed how Python did it. Since switching over to Sphinx, we don't need that file any more.

comment:3 Changed 10 years ago by mhansen

  • Merged in set to sage-4.4.4.alpha0
  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.