Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#9131 closed defect (invalid)

sage-4.4.3.alpha2: OS X 10.4 PPC -- readline fails to build

Reported by: was Owned by: GeorgSWeber
Priority: blocker Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

gcc version 4.0.1 (Apple Computer, Inc. build 5370)
****************************************************
Building a 32-bit version of Readline
Code will be built with debugging information present. Set 'SAGE_DEBUG' to 'no' if you don't want that.
No Fortran compiler has been defined. This is not normally a problem.
Using CC=gcc
Using CXX=g++
Using FC=
Using F77=
Using SAGE_FORTRAN=
Using SAGE_FORTRAN_LIB=
The following environment variables will be exported.
Using CFLAGS= -O2  -g  -Wall 
Using CXXFLAGS= -O2  -g  -Wall
Using FCFLAGS= -O2  -g  -Wall
Using F77FLAGS= -O2  -g  -Wall
Using CPPFLAGS=
Using LDFLAGS=
Using ABI=
configure scripts and/or makefiles might override these later

Deleting old readline headers and libs
./spkg-install: line 204: ./configure: No such file or directory

real    0m0.101s
user    0m0.016s
sys     0m0.062s
sage: An error occurred while installing readline-6.0.p1

Change History (5)

comment:1 Changed 10 years ago by was

  • Milestone changed from sage-4.4.4 to sage-4.4.3

comment:2 Changed 10 years ago by was

This is caused by:

readline-6.0.p1/src/doc/readline.dvi
tar: Skipping to next header
tar: Archive contains obsolescent base-64 headers

bzip2: Data integrity error when decompressing.
        Input file = (stdin), output file = (stdout)

It is possible that the compressed file(s) have become corrupted.
You can use the -tvv option to test integrity of such files.

You can use the `bzip2recover' program to attempt to recover
data from undamaged sections of corrupted files.

tar: Read 3272 bytes from spkg/standard/readline-6.0.p1.spkg
tar: Child returned status 2
tar: Error exit delayed from previous errors

comment:3 Changed 10 years ago by was

I tried using "sage -pkg_nc" instead of "sage -pkg", which produces a non-bzip2 compressed tarball spkg. This completely fixed the above problem. So there is so some subtle issue with bz2 compression and tar on OS X 10.4. Crazy.

Here is the non-bzip2'd readline spkg:

http://sage.math.washington.edu/home/wstein/patches/readline-6.0.p1.spkg

It's 6MB instead of 2MB. I'm just going to leave this here for the record. I'm not proposing this be merged into sage.

comment:4 Changed 10 years ago by was

  • Resolution set to invalid
  • Status changed from new to closed

This went away when I used a new tarball. So it's some random corruption...

comment:5 Changed 10 years ago by mvngu

  • Milestone changed from sage-4.4.3 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.