Opened 12 years ago

Closed 12 years ago

#905 closed enhancement (fixed)

[with package, positive review] update ipython to 0.8.2

Reported by: was Owned by: burcin
Priority: major Milestone: sage-3.0.2
Component: packages: standard Keywords:
Cc: mabshoff Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by was)

this can wait.

Change History (5)

comment:1 Changed 12 years ago by was

  • Description modified (diff)
  • Milestone changed from sage-2.8.8 to sage-2.9

comment:2 Changed 12 years ago by burcin

  • Cc mabshoff added
  • Owner changed from was to burcin
  • Status changed from new to assigned
  • Summary changed from update the version of ipython included in sage to [with package, needs review] update ipython to 0.8.2

New package with upstream version 0.8.2 available here:

http://www.risc.uni-linz.ac.at/people/berocal/sage/ipython-0.8.2.spkg

It works for me.

There are quite a few entries in trac about updating ipython, see #1625, #1264, #1969.

#1625 is a duplicate of this. The problem mentioned in #1264 doesn't happen with 0.8.2. I didn't update to svn as mentioned in #1969, since I don't know if it is stable enough to distribute with Sage.

comment:3 Changed 12 years ago by mabshoff

A couple remarks:

  • no need to add me to the CC - I get email from all tickets anyway
  • there is no hg repo in the spkg. I am fixing that
  • "cp patches/iplib.py src/IPython/iplib.py" should be removed from spkg-install

I will do all those fixes and provided it installs I will give it a positive review.

Cheers,

Michael

comment:4 Changed 12 years ago by mabshoff

  • Summary changed from [with package, needs review] update ipython to 0.8.2 to [with package, positive review] update ipython to 0.8.2

I did all the above cleanups in

http://sage.math.washington.edu/home/mabshoff/release-cycles-3.0.2/alpha0/ipython-0.8.2.p0.spkg

Positive review since it install and doctests pass. Let's hope we didn't break anything else.

Cheers,

Michael

comment:5 Changed 12 years ago by mabshoff

  • Resolution set to fixed
  • Status changed from assigned to closed

Merged in Sage 3.0.2.alpha0

Note: See TracTickets for help on using tickets.