Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8996 closed defect (duplicate)

@ character is usernames is problematic

Reported by: ddrake Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In http://groups.google.com/group/sage-support/t/2acd499a566efce1 a user had troubles because his username is his email address and the @ character messed things up.

We should either allow @ (and similar non-alphanumeric) characters and make things work properly with them, or explicitly disallow them. Note that right now (4.4.1), http://sagenb.org/register says that @ is allowed in usernames!

Change History (4)

comment:1 follow-up: Changed 12 years ago by robertwb

Dupe of #8995 (though this description is slightly more informative). If it's not to hard, I have a strong preference for allowing @ in usernames, as I often use my email address as a username because it's both easy to remember and likely to be unique.

comment:2 Changed 12 years ago by ddrake

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 in reply to: ↑ 1 Changed 12 years ago by ddrake

Replying to robertwb:

Dupe of #8995 (though this description is slightly more informative). If it's not to hard, I have a strong preference for allowing @ in usernames, as I often use my email address as a username because it's both easy to remember and likely to be unique.

I agree. I use my email address as a username for the same reasons.

comment:4 Changed 12 years ago by mvngu

  • Milestone changed from sage-4.4.3 to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.