Opened 9 years ago

Closed 8 years ago

#8995 closed defect (duplicate)

@ sign in notebook username prevents TinyMCE from working

Reported by: jason Owned by: jason, was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: notebook Keywords:
Cc: dimpase Merged in:
Authors: Reviewers: Karl-Dieter Crisman, Dmitrii Pasechnik
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by jdemeyer)

See the thread by Dennis Watson here:

http://groups.google.com/group/sage-support/browse_frm/thread/2acd499a566efce1

In particular, some tinymce javascript files were trying to download from a URL that included the username, like:

http://sagenb.org/home/usernamewith@/javascript/tiny_mce/langs/en.js

See #11343.

Change History (4)

comment:1 Changed 9 years ago by ddrake

#8996 is a duplicate of this (just beaten by Jason!). Robert there says:

If it's not to hard, I have a strong preference for allowing @ in usernames, as I often use my email address as a username because it's both easy to remember and likely to be unique.

...which I agree with.

comment:2 Changed 8 years ago by kcrisman

  • Cc dimpase added
  • Reviewers set to Karl-Dieter Crisman, Dmitrii Pasechnik
  • Status changed from new to needs_review

dimpase just pointed out that #11343 is a dup of this. However, there is a lot more discussion there, as well as a patch, so I'm recommending this be the one closed. I'm copying the description material above there.

comment:3 Changed 8 years ago by kcrisman

  • Milestone changed from sage-4.7.2 to sage-duplicate/invalid/wontfix
  • Status changed from needs_review to positive_review

comment:4 Changed 8 years ago by jdemeyer

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.