Changes between Initial Version and Version 1 of Ticket #8986


Ignore:
Timestamp:
05/18/10 09:31:39 (12 years ago)
Author:
novoselt
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #8986

    • Property Status changed from new to needs_review
    • Property Milestone changed from to sage-4.4.2
    • Property Authors changed from to Andrey Novoseltsev
  • Ticket #8986 – Description

    initial v1  
     1This patch is a part of the following series adding support for cones/fans and toric varieties to Sage:
     2
     3Prerequisites:
     4
     5#8675 - Remove {{{AmbientSpace._constructor}}} and fix consequences
     6
     7#8682 - Improve {{{AlgebraicScheme_subscheme.__init__}}} and {{{AmbientSpace._validate}}}
     8
     9#8694 - Improve schemes printing and !LaTeXing
     10
     11#8934 - Trivial bug in computing faces of non-full-dimensional lattice polytopes
     12
     13#8936 - Expose facet inequalities for lattice polytopes
     14
     15#8941 - {{{_latex_}}} and {{{origin}}} for lattice polytopes
     16
     17Main patches adding new modules:
     18
     19#8986 - Add support for convex rational polyhedral cones
     20
     21#8987 - Add support for rational polyhedral fans
     22
     23#8988 - Add support for toric varieties
     24
     25#8989 - Add support for Fano toric varieties
     26
     27Everything was tested on sage.math using sage-4.4.2.rc0.
     28
     29Known issues:
     30
     31- Applying patch for toric varieties leads to a doctest error in {{{sage.symbolic.random_tests}}}, which I don't quite understand, especially since this patch just adds a new module! The documentation of the failing function says "This function will often raise an error because it tries to create an erroneous expression." I am not sure if this means that its doctest may cause these errors.
     32
     33- The last two patches show a doctest coverage error about {{{TestSuite}}}. This doctest does not work yet for other schemes and therefore should not be expected to work for these derived classes (and indeed - it does not work). According to
     34http://groups.google.com/group/sage-devel/browse_thread/thread/a42ace80078373b4
     35this should not be an obstacle to include these patches.