Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#8826 closed defect (invalid)

[build error] ImportError: No module named sage.all

Reported by: gostrc Owned by: GeorgSWeber
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: build Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

I'm using gcc 4.5 but I'm not sure if this is related. I am on 64bit archlinux. If you need any more info, I'll be happy to provide it.

`spkg/base/.hg/store/data/bzip2-1.0.5-install.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/bzip2-1.0.5-install.i'

`spkg/base/.hg/store/data/_r_e_a_d_m_e.txt.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/_r_e_a_d_m_e.txt.i'
`spkg/base/.hg/store/data/testcxx.sh.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/testcxx.sh.i'
`spkg/base/.hg/store/data/prereq-0.3-install.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/prereq-0.3-install.i'
`spkg/base/.hg/store/data/stdint.h___solaris9.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/stdint.h___solaris9.i'
`spkg/base/.hg/store/data/prereq-0.7-install.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/prereq-0.7-install.i'
`spkg/base/.hg/store/data/.hgignore.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/.hgignore.i'
`spkg/base/.hg/store/data/testcc.sh.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/testcc.sh.i'
`spkg/base/.hg/store/data/prereq-0.6-install.i' -> `/opt/sage/sage/spkg/base/.hg/store/data/prereq-0.6-install.i'
`spkg/base/.hg/store/00changelog.i' -> `/opt/sage/sage/spkg/base/.hg/store/00changelog.i'
`spkg/base/.hg/store/undo' -> `/opt/sage/sage/spkg/base/.hg/store/undo'
`spkg/base/.hg/attic' -> `/opt/sage/sage/spkg/base/.hg/attic'
`spkg/base/.hg/requires' -> `/opt/sage/sage/spkg/base/.hg/requires'
`spkg/base/.hg/branch' -> `/opt/sage/sage/spkg/base/.hg/branch'
`spkg/base/sage-make_relative' -> `/opt/sage/sage/spkg/base/sage-make_relative'
`spkg/base/bzip2-1.0.5.tar.gz' -> `/opt/sage/sage/spkg/base/bzip2-1.0.5.tar.gz'
`spkg/base/.hgignore' -> `/opt/sage/sage/spkg/base/.hgignore'
`spkg/base/README.txt' -> `/opt/sage/sage/spkg/base/README.txt'
`spkg/base/testcxx.sh' -> `/opt/sage/sage/spkg/base/testcxx.sh'
`spkg/base/sage-spkg' -> `/opt/sage/sage/spkg/base/sage-spkg'
`spkg/base/testcc.sh' -> `/opt/sage/sage/spkg/base/testcc.sh'
`spkg/base/bzip2-1.0.5-install' -> `/opt/sage/sage/spkg/base/bzip2-1.0.5-install'
`spkg/base/prereq-0.7-install' -> `/opt/sage/sage/spkg/base/prereq-0.7-install'
`tmp' -> `/opt/sage/sage/tmp'
`tmp/COPYING.txt' -> `/opt/sage/sage/tmp/COPYING.txt'
`tmp/README.txt' -> `/opt/sage/sage/tmp/README.txt'
`tmp/sage-README-osx.txt' -> `/opt/sage/sage/tmp/sage-README-osx.txt'
`tmp/install' -> `/opt/sage/sage/tmp/install'
python local/bin/sage-hardcode_sage_root /opt/sage/sage/sage "/opt/sage"/sage
cp /opt/sage/sage/sage /opt/sage/bin/
cd /opt/sage/bin/; ./sage -c
Traceback (most recent call last):
  File "/opt/sage/sage/local/bin/sage-eval", line 4, in <module>
    from sage.all import *
ImportError: No module named sage.all

make: * [install] Error 1
error: command failed to execute correctly

Change History (4)

comment:1 Changed 12 years ago by gostrc

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in 4.4.1

comment:2 Changed 12 years ago by gostrc

  • Resolution fixed deleted
  • Status changed from closed to new

comment:3 Changed 12 years ago by gostrc

  • Resolution set to fixed
  • Status changed from new to closed

had to unset LDFLAGS MAKEFLAGS CFLAGS CXXFLAGS

comment:4 Changed 12 years ago by mhansen

  • Milestone changed from sage-4.4.4 to sage-duplicate/invalid/wontfix
  • Resolution changed from fixed to invalid
Note: See TracTickets for help on using tickets.