Opened 10 years ago

Closed 10 years ago

#8787 closed enhancement (fixed)

upgrade the openssl optional spkg to version 1.0

Reported by: was Owned by: tbd
Priority: major Milestone: sage-4.5
Component: packages: optional Keywords:
Cc: schilly Merged in: sage-4.5.rc0
Authors: William Stein Reviewers: Mariah Lenox
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description

Amazingly, openssl released version *1.0*! Let's upgrade to this.

Change History (9)

comment:1 Changed 10 years ago by was

  • Status changed from new to needs_review

Here is the spkg:

http://wstein.org/home/wstein/patches/openssl-1.0.0.spkg

I fixed things to be "modern" and up to snuff -- a formatted SPKG.txt file, a .hg directory, error messages not all messed up in spkg-install, a src/ directory, etc.

comment:2 Changed 10 years ago by schilly

  • Cc schilly added

comment:3 follow-up: Changed 10 years ago by mariah

  • Status changed from needs_review to needs_work

Sadly, building sage-4.3.5 with gcc-4.4.3 and openssl-1.0.0.spkg did NOT work on one of my company's computers (not connected to the Internet). The machine is similar hardware to Skynet/taurus, but running Red Hat Enterprise Linux Server.

First I installed openssl-1.0.0.spkg. Then I did 'make testlong'. The build failed while trying to build python-2.6.4.p7 with the message

import _md5

Import Error: No module named _md5 hashlib module failed to import

comment:4 in reply to: ↑ 3 ; follow-up: Changed 10 years ago by was

Replying to mariah:

Sadly, building sage-4.3.5 with gcc-4.4.3 and openssl-1.0.0.spkg did NOT work on one of my company's computers (not connected to the Internet). The machine is similar hardware to Skynet/taurus, but running Red Hat Enterprise Linux Server.

First I installed openssl-1.0.0.spkg. Then I did 'make testlong'. The build failed while trying to build python-2.6.4.p7 with the message

Can you post the log that results from doing

sage -f openssl-1.0.0

and also the log that results from building python, e.g.,

sage -f python-2.6.4.p7

Also, did you get this failure on taurus? If so, I can just test there.

comment:5 in reply to: ↑ 4 ; follow-up: Changed 10 years ago by mariah

Can you post the log that results from doing

sage -f openssl-1.0.0

and also the log that results from building python, e.g.,

sage -f python-2.6.4.p7

I do not believe I am allowed to export the logs. This problem is happening on one of our internal company machines.

Also, did you get this failure on taurus? If so, I can just test there.

I tried to reproduce the problem on taurus, but sadly the problem does NOT seem to be reproducible on taurus.

comment:6 in reply to: ↑ 5 Changed 10 years ago by mariah

I have investigated the problem and found that 
the reason for the failure is that openssl-1.0.0
puts libraries in $SAGE_ROOT/local/lib64 on 64-bit 
machines. Sage does not add $SAGE_ROOT/local/lib64
to the LD_LIBRARY_PATH.

If you add

  --libdir=lib

to the ./config line in spkg-install, then sage
builds with openssl-1.0.0 and all tests pass.

comment:7 Changed 10 years ago by was

  • Status changed from needs_work to needs_review

I've posted a new spkg with the fix you suggest here:

http://wstein.org/home/wstein/patches/openssl-1.0.0.p0.spkg

comment:8 Changed 10 years ago by mariah

  • Status changed from needs_review to positive_review

On the machine where I previously was having problems, openssl-1.0.0.p0.spkg builds and 'make testlong' on sage-4.4.3 passes all tests.

Thus I give this package a positive review!

comment:9 Changed 10 years ago by rlm

  • Authors set to William Stein
  • Merged in set to sage-4.5.rc0
  • Resolution set to fixed
  • Reviewers set to Mariah Lenox
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.