Changes between Initial Version and Version 12 of Ticket #8783


Ignore:
Timestamp:
07/06/10 11:50:24 (12 years ago)
Author:
broune
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #8783

    • Property Status changed from new to needs_review
    • Property Report Upstream changed from N/A to Fixed upstream, in a later stable release.
  • Ticket #8783 – Description

    initial v12  
    1 {{{
    2 frobby-0.7.6/src/test/transform/t3.gen.m2
    3 frobby-0.7.6/src/test/transform/t3.gen.nm
    4 Finished extraction
    5 ****************************************************
    6 Host system
    7 uname -a:
    8 Linux eno 2.6.32.10-90.fc12.x86_64 #1 SMP Tue Mar 23 09:47:08 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux
    9 ****************************************************
    10 ****************************************************
    11 CC Version
    12 gcc -v
    13 Using built-in specs.
    14 COLLECT_GCC=gcc
    15 COLLECT_LTO_WRAPPER=/usr/local/gcc-4.5.0/x86_64-Linux-core2-fc/libexec/gcc/x86_64-unknown-linux-gnu/4.5.0/lto-wrapper
    16 Target: x86_64-unknown-linux-gnu
    17 Configured with: /usr/local/gcc-4.5.0/src/gcc-4.5.0/configure --enable-languages=c,c++,fortran --with-gnu-as --with-gnu-as=/usr/local/binutils-2.20.1/x86_64-Linux-core2-fc-gcc-4.4.3-rh/bin/as --with-gnu-ld --with-ld=/usr/local/binutils-2.20.1/x86_64-Linux-core2-fc-gcc-4.4.3-rh/bin/ld --with-gmp=/usr/local/mpir-1.2.2/x86_64-Linux-core2-fc-gcc-4.4.2 --with-mpfr=/usr/local/mpfr-2.4.2/x86_64-Linux-core2-fc-mpir-1.2.2-gcc-4.4.2 --with-mpc=/usr/local/mpc-0.8.1/x86_64-Linux-core2-fc-mpfr-2.4.2-mpir-1.2.2-gcc-4.4.3-rh --prefix=/usr/local/gcc-4.5.0/x86_64-Linux-core2-fc
    18 Thread model: posix
    19 gcc version 4.5.0 (GCC)
    20 ****************************************************
    21 mkdir -p bin/release/
    22 g++ -Wall -ansi -pedantic -Wextra -Wno-uninitialized -Wno-unused-parameter -Werror -isystem /home/wstein/screen/eno/sage-4.3/local/include -O3 -c src/main.cpp -o bin/release/main.o
    23 src/main.cpp: In function ‘int main(int, const char**)’:
    24 src/main.cpp:30:16: error: ‘srand’ was not declared in this scope
    25 make: *** [bin/release/main.o] Error 1
    26 Error building Frobby.
     1Thanks for the prompt review. I committed the outstanding files in the repository and removed the two ~ files. The result is up in the same place:
    272
    28 real    0m0.614s
    29 user    0m0.283s
    30 sys     0m0.052s
    31 sage: An error occurred while installing frobby-0.7.6
    32 Please email sage-devel http://groups.google.com/group/sag
    33 }}}
     3 http://sage.math.washington.edu/home/bjarke/frobby-0.7.6.p1.spkg
     4
     5I'm adding patches rather than edit src/ because as I understand it the code in src/ must be an official release of the upstream code. No version 0.7.6 of Frobby exists that compiles under gcc 4.3.0, and I'd rather add some patches here than make an official release of an old version.