Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8697 closed defect (duplicate)

Add basic generic test methods

Reported by: nthiery Owned by: tbd
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: doctest coverage Keywords: generic tests
Cc: Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In SageObject?:

  • _test_eq: tests self == self, (self != self) == False, (self == None) == False, self != None (this would have caught #8695)
  • _test_hash: test that the result of hash is an int or that it raises an appropriate exception
  • Please Florent, add here what we had thought about

Change History (3)

comment:1 in reply to: ↑ description ; follow-up: Changed 11 years ago by hivert

  • Please Florent, add here what we had thought about

This looks like a duplicate of #8402... and should be closed.

comment:2 in reply to: ↑ 1 Changed 11 years ago by nthiery

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to hivert:

  • Please Florent, add here what we had thought about

This looks like a duplicate of #8402... and should be closed.

Oops, right. Sorry.

comment:3 Changed 11 years ago by mvngu

  • Milestone set to sage-duplicate/invalid/wontfix
Note: See TracTickets for help on using tickets.