Opened 9 years ago

Closed 3 years ago

#8672 closed enhancement (fixed)

SCIP support

Reported by: ncohen Owned by: jason, jkantor
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: linear programming Keywords:
Cc: malb, schilly, r.gaia.cs Merged in:
Authors: Reviewers: Vincent Delecroix
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Description (last modified by ncohen)

Based upon Harald Schilly's SPKG for SCIP, here is a patch to enable the use of this solver through the usual interface for LP.

Requires #8172 (though none of GLPK, CBC or CPLEX needs to be installed)

Nathann

Attachments (1)

trac_8672.patch (5.1 KB) - added by ncohen 9 years ago.

Download all attachments as: .zip

Change History (14)

comment:1 Changed 9 years ago by ncohen

  • Description modified (diff)
  • Status changed from new to needs_review

comment:2 Changed 9 years ago by schilly

wow, thank you!! just one thing, is it possible to enable verbose output if enabled? i don't know which parameter you have to set in Sage's MIP interface, but it is scip.solver(quiet=False) in scip.

comment:3 Changed 9 years ago by ncohen

Fixed ! The corresponding argument in sage is log=# in the solve method. 0 for no output, and integers to have progressdively more (only GLPk has different levels of output though, the others only understand 0/1 or none at all )

Nathann

Changed 9 years ago by ncohen

comment:4 Changed 9 years ago by malb

  • Status changed from needs_review to needs_work

Hi Nathann,

two small things:

  • solve_scip has no documentation/doctests
  • "the default solver is used (COIN if available, GLPK otherwise)" seems to be inaccurate since you also try SCIP whether it is available

comment:5 Changed 9 years ago by ncohen

  • Component changed from numerical to linear programming

comment:6 Changed 7 years ago by r.gaia.cs

  • Cc r.gaia.cs added

comment:7 Changed 6 years ago by jdemeyer

  • Milestone changed from sage-5.11 to sage-5.12

comment:8 Changed 6 years ago by vbraun_spam

  • Milestone changed from sage-6.1 to sage-6.2

comment:9 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.2 to sage-6.3

comment:10 Changed 5 years ago by vbraun_spam

  • Milestone changed from sage-6.3 to sage-6.4

comment:11 Changed 3 years ago by mkoeppe

  • Milestone changed from sage-6.4 to sage-duplicate/invalid/wontfix
  • Status changed from needs_work to needs_review

Duplicate of #10879, so I'm marking this one as "needs_review" so it can be closed -- hoping this is the correct procedure.

comment:12 Changed 3 years ago by vdelecroix

  • Reviewers set to Vincent Delecroix
  • Status changed from needs_review to positive_review

comment:13 Changed 3 years ago by vbraun

  • Resolution set to fixed
  • Status changed from positive_review to closed
Note: See TracTickets for help on using tickets.