Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#8634 closed defect (duplicate)

Broken conversion of sage variable h1 to Maxima

Reported by: robert.marik Owned by: robert.marik
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: symbolics Keywords:
Cc: kcrisman, burcin Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

h1, h2, h9 (and perhaps some others) are converted into binomial coefficients. This disallows to solve an equation involving variable h1.

----------------------------------------------------------------------
| Sage Version 4.3.4, Release Date: 2010-03-19                       |
| Type notebook() for the GUI, and license() for information.        |
----------------------------------------------------------------------
sage: h1=var('h1'); h1._maxima_()
binomial(n,k)*x^k
sage: h2=var('h2'); h2._maxima_()
binomial(a,k)*binomial(b,n-k)
sage: h=var('h'); h._maxima_()
h
sage: h_1=var('h_1'); h_1._maxima_()
h_1
sage: h23=var('h23'); h23._maxima_()
h23
sage: ch1=var('ch1'); ch1._maxima_()
ch1
sage: h9=var('h9'); h9._maxima_()
n!/(k!*(m+k)!*(n-m-2*k)!)

Change History (4)

comment:1 Changed 11 years ago by robert.marik

  • Owner changed from burcin to robert.marik

The discussion at sage-devel

comment:2 Changed 11 years ago by robert.marik

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #8734 which already has first draft for the patch.

comment:3 Changed 11 years ago by robert.marik

Oops, I wanted to mark this ticket as duplicate and the ticket has been closed automatically. Sorry for this, I know that only the release manager should close tickets :).

comment:4 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.4 to sage-duplicate/invalid/wontfix

Close as duplicate of #8734.

Note: See TracTickets for help on using tickets.