Opened 11 years ago

Closed 10 years ago

#8575 closed defect (duplicate)

Sphinx should raise warning in case of ill formated enumerated lists

Reported by: hivert Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords: Sphinx, warning
Cc: jhpalmieri, mpatel Merged in:
Authors: Reviewers: Florent Hivert
Report Upstream: Completely fixed; Fix reported upstream Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

In some cases, for example when an enumerated list is ill formated, in text mode ouput sphinx returns silently an empty string. It should at least raise some warning. See #8572 for an instance of the problem. At this point, I don't know if it's a bug of sphinx or the way we call it.

Change History (8)

comment:1 Changed 11 years ago by hivert

  • Cc jhpalmieri mpatel added

comment:2 Changed 11 years ago by hivert

There is a very good chance that this is a bug of sphinx. I asked it on sphinx-dev. I'm waiting for their answer.

For the info, here is a ReST file that triggers the problem:

**************************
List Bug Triggering Module
**************************

    - list item 1 -- this item is correctly formated. So that there should be
      no problem with it..

    - list item 2 -- this item is ill formated. Sphinx should raise a warning
       when typesetting in in text mode.

Florent

comment:3 follow-up: Changed 11 years ago by hivert

  • Report Upstream changed from N/A to Fixed upstream, in a later stable release.

This is indeed a bug of sphinx (see this Sphinx-dev thread). Georg Brandl answered:

The behavior is clearly a bug, and I've now fixed it in changeset 93ae46825651 in the 0.6 branch. It will be part of the next bugfix release.

I'm not sure what to do now with this ticket... Should we back port the bugfix or wait for the next release ? Should this ticket be left open ?

Florent

comment:4 in reply to: ↑ 3 ; follow-up: Changed 11 years ago by mvngu

Replying to hivert:

I'm not sure what to do now with this ticket... Should we back port the bugfix or wait for the next release ? Should this ticket be left open ?

I would think wait for the next release, as that is (maybe) much easier than backporting. If you can backport, then by all means do so. Until the issue is fixed by upgrading to the new release with the bug fixed, or backporting, this ticket would remain open.

comment:5 in reply to: ↑ 4 Changed 11 years ago by hivert

  • Status changed from new to needs_info
  • Work issues set to Sphinx release 0.6.6

Replying to mvngu:

I would think wait for the next release, as that is (maybe) much easier than backporting. If you can backport, then by all means do so. Until the issue is fixed by upgrading to the new release with the bug fixed, or backporting, this ticket would remain open.

According to Georg Brandl, Sphinx should make a new bugfix release "soon"... So I'm in favor of waiting for it.

comment:6 Changed 10 years ago by hivert

  • Report Upstream changed from Fixed upstream, in a later stable release. to Completely fixed; Fix reported upstream
  • Reviewers set to Florent Hivert
  • Status changed from needs_info to needs_review

This ticket should be closed since sage uses now sphinx 1.0.4

(WARNING/2) Bullet list ends without a blank line; unexpected unindent.

I set this to positive review.

comment:7 Changed 10 years ago by hivert

  • Status changed from needs_review to positive_review

comment:8 Changed 10 years ago by jdemeyer

  • Milestone changed from sage-4.7 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from positive_review to closed
  • Work issues Sphinx release 0.6.6 deleted
Note: See TracTickets for help on using tickets.