Opened 15 years ago

Closed 15 years ago

#85 closed defect (fixed)

incorrect p-adic arithmetic for negative numbers with infinite precision

Reported by: dmharvey Owned by: dmharvey
Priority: major Milestone:
Component: basic arithmetic Keywords:
Cc: Merged in:
Authors: Reviewers:
Report Upstream: Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

sage: pAdicField(5, 3)(-1)
 4 + 4*5 + 4*5^2 + O(5^Infinity)

I know where the bug is.... it's all my fault....

Change History (3)

comment:1 Changed 15 years ago by dmharvey

I've fixed this (patch to be submitted soon), but the problem is deeper, it's not just to do with coercion, e.g.

sage: K = pAdicField(5, 3)
sage: K(2) - K(3)
 4 + 4*5 + 4*5^2 + O(5^Infinity)

comment:2 Changed 15 years ago by dmharvey

  • Summary changed from p-adic coercion incorrect for negative numbers to incorrect p-adic arithmetic for negative numbers with infinite precision

comment:3 Changed 15 years ago by dmharvey

  • Resolution set to fixed
  • Status changed from new to closed

fixed in sage 1.4

Note: See TracTickets for help on using tickets.