Opened 11 years ago

Closed 11 years ago

#8467 closed enhancement (duplicate)

move the document "Linear Programming in Sage" to "Thematic Tutorials"

Reported by: mvngu Owned by: mvngu
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: documentation Keywords: linear programming
Cc: ncohen, jason Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description (last modified by ncohen)

Move the document "Linear Programming in Sage", found here and here, to the classification "Thematic Tutorials". The original proposal can be found on sage-devel and sage-combinat-devel.

Notes: The current ticket needs to be coordinated with #8470.

Depends on #7311

The methods detailed in this Howto, along with some features used, makes it dependent also on :

Nathann

Attachments (2)

linear_programming2.rst (32.8 KB) - added by ncohen 11 years ago.
linear_programming2_some_changes.rst (33.6 KB) - added by pang 11 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 11 years ago by mvngu

  • Description modified (diff)

comment:2 Changed 11 years ago by ncohen

  • Description modified (diff)
  • Status changed from new to needs_work

Here is where I have for the moment. I still need to rewrite LP examples for some problems, but at least I reformatted everything for Sphinx.

It will require the new LP patch enabling a new syntax for constraints #7311

Nathann

comment:3 Changed 11 years ago by ncohen

Oh yes, and there is also something to take care of : the new patch for CPLEX support brings changes to the current LP document in the Constructions manual... Only a few lines concerning CPLEX at the end of it, and some fixes, but we should not lose it when deleting the current document and replacing it with this one in the HOWTO manual :-)

Nathann

comment:4 Changed 11 years ago by mvngu

  • Description modified (diff)
  • Summary changed from move the document "Linear Programming in Sage" to "Sage HOWTOs" to move the document "Linear Programming in Sage" to "Thematic Tutorials"

comment:5 Changed 11 years ago by ncohen

this version passes doctests !

Nathann

comment:6 Changed 11 years ago by ncohen

  • Description modified (diff)
  • Status changed from needs_work to needs_review

Here it is ! :-)

Changed 11 years ago by ncohen

comment:7 Changed 11 years ago by jason

  • Cc jason added

comment:8 Changed 11 years ago by pang

I've read up to the "Maximum average degree" problem, and I have some found some errata:

  • line 63: Errata on example LP
  • line 161: maximization instead of minimization
  • line 177: missing objective function
  • line 200-204: problem not written properly
  • line 204: alternative formulation with only one variable for each edge

I adjoint a rst file with corrections. The example on "Maximum average degree" is correct but I find it harder to follow than the previous ones, for a non-expert in graph-theory. I don't know which is the target audience...

Changed 11 years ago by pang

comment:9 Changed 11 years ago by ncohen

  • Status changed from needs_review to needs_work

Thank you very much for reading it until then !!! Actually, I will need to change some parts of it now that GLPK is a standard SPKG. I will also update the end of it, to give more natural examples :-)

I am setting it to "needs work" until this is done !!

Nathann

comment:10 Changed 11 years ago by jhpalmieri

When this is ready, could you produce it as a Mercurial patch file?

comment:11 Changed 11 years ago by ncohen

Of course of course ! :-)

comment:12 Changed 11 years ago by ncohen

This ticket should be closed as a duplicate of #9836 :-)

Nathann

comment:13 Changed 11 years ago by mvngu

  • Milestone changed from sage-4.6 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from needs_work to closed

Close as duplicate of #9836.

Note: See TracTickets for help on using tickets.