Opened 11 years ago

Closed 11 years ago

#8461 closed defect (duplicate)

Numerical noise in /sage/sage/plot/colors.py

Reported by: drkirkby Owned by: was
Priority: major Milestone: sage-duplicate/invalid/wontfix
Component: graphics Keywords:
Cc: kcrisman, robertwb, wcauchois Merged in:
Authors: Reviewers:
Report Upstream: N/A Work issues:
Branch: Commit:
Dependencies: Stopgaps:

Status badges

Description

Running Solaris 10 on a SPARC, I get some numerical noise on this. Since these are RGB values.

**********************************************************************
File "/export/home/drkirkby/32/sage-4.3.4.alpha0/devel/sage/sage/plot/colors.py", line 660:
    sage: gold / pi + yellow * e
Expected:
    RGB color (0.51829585732141792, 0.49333037605210095, 0.0)
Got:
    RGB color (0.51829585732141814, 0.49333037605210117, 0.0)
**********************************************************************

The test makes use of 'e'. As has been shown on various other trac tickets (e.g. #8374, #8375), the value of 'e' returned by the SPARC processor is less accurate then the Intel/ADM chips.

I'll attach a patch soon.

Dave

Change History (2)

comment:1 Changed 11 years ago by drkirkby

This can be closed as a duplicate of #8462. It's better to do it this way, rather than close the later ticket, as that has a patch and more information attached.

dave

comment:2 Changed 11 years ago by mhansen

  • Milestone changed from sage-4.3.4 to sage-duplicate/invalid/wontfix
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.